I need to back up the configurations on my routers and main switches. I have installed the the tftpd64.exe tool on my local machine and am accessing the router via Telnet. I have bound the IP appropriately and am configured like this:

enter image description here

The instructions for doing so were obtained here (everything is the same except I am using the 64 bit version).

When I run the command, which I found here, I get the error shown in the image. Nothing appears in the TFTP logs, so it looks like the connection is failing. Now, I tested the TFTP installation by opening a command prompt and going to a local folder and applying the command like this:

tftp -i get filename.ext

In fact, the file was not transferred and I received a "file not found" error in the TFTP log. However, when I tried again like this,

tftp -i put filename.ext

the file was transferred successfully. This is at odds with the proper command string as defined in the video in the link I supplied. I'm not sure how this relates to the error I'm getting with the Telnet "copy run" command, but it is indicative of a potential misconfiguration or something so I thought it pertinent to the discussion.

My question is, how can I make this Telnet connection copy the config file from my router? Everything appears to be configured correctly and it works on the client side but not with the correct "get" command. How do I troubleshoot this? The router is a Cisco Catalyst 3750, and I am running Windows 10 Professional 64 bit.

1 Answer 1


I resolved this problem by going into settings in the TFTP tool and binding to the IP associated with my VPN. That fixed it for me, at least as far as copying my config files from the router.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.