19

I have my job IMAP account set up in TB 3.0.3.

It's becoming very annoying that in group emails where I'm in the CC or TO list I hit "Reply To All" and I find myself in the recipients list. So when I send the email I also get a copy of my own email.

I haven't found where to disable or modify this.

This doesn't happen with my Gmail account (also set up in TB)

25

The Reply to All feature works the way you want only when your e-mail address in the e-mail you are replying to is the same as configured in the account.

In this case, you should add another Identity to your account which uses the other e-mail address.

  • Right-click on you account name
  • Choose Settings...
  • Click on Manage Identities...
  • Add an Identity using the e-mail address for which Reply to All did not work correctly.

You might also have to set the config option mailnews.reply_to_self_check_all_ident to true.

5
  • 1
    Just to giv emy $0.02: This will not work if your company has aliases setup. You have to use the actual email address in Identity settings. Sometimes companies give you a leeway of setting up aliases of your choice in case you do not like the email address policy of the company or in case you work for a particular sub organization of that company. – sabertooth Aug 16 '10 at 15:00
  • 2
    @AJ: but this should still work, every e-mail that is added as a new "identity" in Thunderbird is correctly identified in "Reply to All" – Palmin Oct 13 '10 at 9:13
  • @Palmin I had a similar issue. Then I added both my actual email and corresponding alias in the identity list and it fixed the problem. – rph Mar 27 '17 at 3:00
  • Just an observation: This solution won't work if the email addresses for each identity, except maybe the default identity, are also saved as contacts in your address book. Be sure to delete yourself from it. – Anthony Pulido Mar 21 '20 at 1:03
  • This still doesn't work when I am replying to an e-mail sent to my alias and my original account is CCed as well. – Michael Jul 27 '20 at 18:54
3

Yes! I found finally an answer to this one!

(in windows version)

Go Tools>Options>General tab>Config Editor... button

(in later versions, the Config Editor is on the Advanced tab)

Type in mailnews.reply_to_self_check_all_ident

Double-click it to set it to false

Close about:config window (little x upper right).

Press OK to close the options.

Then try replying to a message you sent.

Should leave you out of the To: and CC: fields. Reply just does the To:'s from the original message. Reply All does the To:'s and the CC's.

Farkin fantashtick!

(Windows Vista, Thunderbird 3.06)

2
  • You missed out the most important part (see accepted answer). Without this it will not work ... Right-click on you account name Choose Settings... Click on Manage Identities... Add an Identity using the e-mail address for which Reply to All did not work correctly. – Mawg says reinstate Monica May 19 '14 at 2:43
  • this doesn't work for me under Linux – Michael Jul 27 '20 at 18:57
1

Just adding a stupidity check:

I lately have had this issue coming out of nowhere, after many many years with Thunderbird. But after a change of setup.

I was really annoyed, but did not have time really to look around. This evening I finally went down to look for the source of it. It was a typo in my identity address. It did not show because my user accounts are different than my identity address. Easy to miss : phlippel instead of philippel ...

So look for typos! Cheers,

0
0

In case none of the above work for you, ensure you don't have a typo in your email address. I managed to do this because our SMTP server enforces a From header anyway, so mail was unhindered and the outside world never saw it. The only hint was that Reply all included me.

0

The trick about managing identities and adding your alternate email alias is a good one - it does solve the problem, but if you use an irritating email provider like Verizon, it won't actually allow you to send the message. As of a month or so ago, they stopped allowing email aliases such as your own domain name to be used. Very, very annoying! But it would be nice if Thunderbird had a way to let you list your email aliases just for the purpose of removing your own email address from the reply-to list.

-1

It's not a bug, it's a feature :). Some people like it, like this one.

This should only happen whenever you reply to thread that you have began yourself. Then they will put you into To field, while others will go into Cc field.

Also try downgrading to the older version. Seems like they have changed it recently.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.