1

I am running a dual boot Ubuntu/Windows 10 on a Lenovo t460p. In order to resolve hdd issues between the operating systems I disabled hibernate in Windows:

powercfg /h off

Since I did this change (confirmed as when I enable hibernate, all works as expected), Windows doesn't shutdown anymore, but always restarts when I hit the shutdown button. It is the second clean install I did and the issue is definitely caused by switching off hibernate. I can't find any restart problems that are related to fast startup settings and hope somebody can point in the right direction.

Thanks!

  • I suspect this has something to do with the fact that shutdown will close all programs and then put windows to sleep. Your title suggests you have fast startup disabled, which would not use the hibernation anyway. Is this correct? – LPChip Apr 23 '17 at 9:24
  • That's right, fast startup (which depends on hibernate as far as I know) is disabled; What I did is: I did a clean install, disabled fast startup and this odd behaviour occurs. After enabling it again, Windows shut down fine. – tworabbits Apr 23 '17 at 9:28
  • Maybe you can try this : pcadvisor.co.uk/how-to/windows/… – Vylix Apr 23 '17 at 9:34
  • No, that doesn't change anything. – tworabbits Apr 23 '17 at 10:53
  • Just to confirm, did you already perform the steps described within this previous question? Shutdown Windows 10 truly for a dual booting system. If so, you shouldn't really need to disable hibernate with the powercfg command. You can simply turn it off within advanced power options – Run5k Apr 23 '17 at 11:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.