1

Latest available version of libxml2 is 2.9.4-r2 (alpine linux v3.5). But due to regression bug I need to install 2.9.3 or earlier. How can I do this without downgrade of whole alpine to v3.1?

I'm trying to use apk add command like in this question, but getting an error:

/ # apk add 'libxml2<2.9.4'
ERROR: unsatisfiable constraints:
  libxml2-2.9.4-r2:
    breaks: world[libxml2<2.9.4]

If I add -r0 suffix to version - same result.

1

Try something like this:

# echo 'http://dl-cdn.alpinelinux.org/alpine/v3.1/main' >> 
/etc/apk/repositories

# apk add 'libxml2==2.9.2-r2'
|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.