2

So I've found a frustrating issue. In the past (Windows 7) automounting of disk volumes could be disabled through either diskpart -> automount disable or mountvol /N both of which set the Registry key:

HKLM/System/CurrentControlSet/Services/mountmgr/NoAutoMount

Having done the same in Windows 10 Ent LTSB 2016 (1607), even while the registry key is set, the OS happily proceeds to mount and assign drive letters anyway.

I have made sure to run diskpart -> automount scrub as well as diskpart -> san policy=offlineall (and checked the relevant registry key) to no avail.

Am I just SOL on this or is there a new 'home' for this setting?

Edit Diskpart output as requested:

DISKPART> automount

Automatic mounting of new volumes disabled.

DISKPART>
  • What build are you using exactly "Windows 10 Enterprise 2016" isn't clear. I suspect you mean 1607 or 1511 but I am not entirely sure. – Ramhound Apr 24 '17 at 20:06
  • @Ramhound LTSB 2016 is based on 1607 – Andrew Haskell Apr 24 '17 at 20:08
  • You created a REG_SZ key with a decimal value 1, right? – Ramhound Apr 24 '17 at 20:09
  • I didn't manually create it, diskpart created it initially. Interestingly diskpart created it as a REG_DWORD. I can find some references online to it being a DWORD as well as references for it being a String. I'll try swapping the type. – Andrew Haskell Apr 24 '17 at 20:13
  • Reg.exe Offline registry edit. Besides that within the diskpark command just type automount and supply us the output. I can't find any reference to automount purge for the diskpart documentation. inidcates scrub might help. This indicates that there are only 3 values for it also, none of which, appears to be offlineall – Ramhound Apr 24 '17 at 20:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.