3

Chrome used to open new window just like that: new window appears.

Now new windows appear with animation: it starts with a smaller window (~80%), then it increases to full screen.

How to disable this animation?

Chrome Version 58.0.3029.81 (64-bit) on Ubuntu

(other windows appear without animations)

5

You can disable the animation by adding the --wm-window-animations-disabled command-line flag.

For Linux/Ubuntu you can make this permanent by editing the Chrome shortcut at /usr/share/applications/google-chrome.desktop. There are 3 Exec= lines where you will need to add --wm-window-animations-disabled immediately after the executable name.

If you find that this is no longer working, re-check your shortcuts as some Chrome updates (via a package manager) could have overwritten the shortcut(s), so you may need to re-edit them.

|improve this answer|||||
  • thank you so much! (because of this i already started switching to firefox... but now back to chrome) – Ayrat Apr 28 '17 at 13:38
  • This isn't working for me. Ubuntu 17.04 Chrome 58.0.3029.110 i3 desktop. Also this question is repeated at stackoverflow.com/questions/43607461/… – Zamicol Jun 5 '17 at 6:13
  • mscdex, why would you remove my addition to your answer ? giving a single command fix sounds like a good idea to me. Especially when you have to repeat after each updates. – PowerKiKi Jun 29 '17 at 8:47
0

You can add the flag --wm-window-animations-disabled to all shortcuts used to launch Chrome with the following command:

sudo replace "Exec=/usr/bin/google-chrome-stable" "Exec=/usr/bin/google-chrome-stable --wm-window-animations-disabled" -- /usr/share/applications/google-chrome.desktop
|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.