5

Most menus and context menus on my Windows 10 machine are mostly black until I hover my mouse-pointer over them to "reveal" the entries.

Here is a gif of how that looks:

enter image description here

Things I tried that did not help:

  • Restart the computer. Menus look fine for a while after a restart, but the problem reappears. I did not have the patience to try and narrow this down to an application that might cause this.
  • Install the latest Windows version: The problem appeared on the original Windows 10 build as well as the Anniversary Update and the Creator's Update.
  • Install the latest graphics drivers
  • Try another graphics card: The problem appeared both with the integrated Intel Graphics (Intel HD 4600) as well as a Radeon HD 5450

A workaround that did fix the problem:

  1. Go to System Properties > Advanced > Performance > Settings > Visual Effects
  2. Uncheck "Fade or slide menus into view" (or simply choose "Adjust for best performance" to uncheck everything)
  3. Click "Apply"

Menus are no longer black after doing this. But it still feels somewhat wrong - is there a better way?

2

I had the same issue, and my fix was to disable just the "fade or slide menus into view" option. I believe it's likely a display driver bug -- I am using the latest drivers (as of writing) for the nVidia GTX 680. So, a similar fix as yours, but one which will allow you to enable the other "best appearance" features.

  • Do you, by any chance, have this problem on an HP machine? – David Sep 6 '17 at 19:48
  • No, it's not an HP machine. – Paul Bunn Sep 7 '17 at 20:21
  • In French, it is called "Faire disparaître ou apparaître les menus". – Wok Sep 30 '19 at 6:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.