1

Since the last update of Windows 10 (KB4016240), my xampp server does not launch any more imagick, it was working fine before this update.

Now when I start Apache from Xampp I get the error message:

the procedure entry point PixelGetFuzz could not be located in the dynamic link library c:\xampp\php\ext\php_imagick.dll

So I thought it was a PATH Environment issue and I reinstalled Imagemagick with no success.

Imagemagick version (convert --version):

Version: ImageMagick 6.9.3-10 Q16 x86 2016-05-04 http://www.imagemagick.org
Copyright: Copyright (C) 1999-2015 ImageMagick Studio LLC
License: http://www.imagemagick.org/script/license.php
Visual C++: 180040629
Features: Cipher DPC Modules OpenMP
Delegates (built-in): bzlib cairo flif freetype jng jp2 jpeg lcms lqr openexr pangocairo png ps rsvg tiff webp xml zlib

Xampp Control Panel version: 3.2.2

php version: 5.6.23

What can I do?

Edit: I uninstalled the update KB4016240 and I still have the problem. So this appeared maybe because I had to reboot my computer and to restart Apache. I don't do it often and maybe I changed something while Apache was running without restarting it.

  • 1
    Open the DLL in Dependency Walker, which shows all the exported functions of a DLL. Check whether PixelGetFuzz is listed. – Archimaredes Apr 26 '17 at 16:59
  • Here is the result: cjoint.com/doc/17_04/GDArpPLumhc_errors-imagick-dll.jpg I have to find the good php_imagick.dll which correspond to my Imagemagick installation. – London Smith Apr 26 '17 at 17:17
  • Did you find PixelGetFuzz if you scroll down that list? – Archimaredes Apr 26 '17 at 17:22
  • Ok, thank you for your help, it was because of GraphicsMagick. More info on my message I edited. – London Smith Apr 26 '17 at 17:40
  • 1
    Ok, done but I have the message "You can accept your own answer in 2 days". I don't have to forget to accept it on next Friday. :P – London Smith Apr 26 '17 at 17:46
1

Ok, found and well stay close on your seat!

It was because of GraphicsMagick http://www.graphicsmagick.org/ which I installed last week after php Imagick, I didn't restarted Apache from this GraphicsMagick installation. So what I did is : I uninstalled GraphicsMagick, Imagemagick and I reinstalled Imagemagick, reput the file php_imagick.dll I was using.

And now, everything is working like a charm.

It was because of GraphicsMagick, how is it possible?

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.