1

I am really interested in programming, so i tryed to install Linux. I used a bootable USB Flashdrive to boot the iso and started following the german tutorial from the Arch-Linux Wiki. I have a 120 GB SSD with Windows on it and a 2TB HDD which I shrank down 200GB to make space for Linux. I used gdisk to create a root and swap partition using gpt. After rebooting to check if my date on the 2TB drive was ok, I couldn't boot windows and the Arch-Linux ISO bootscreen looked different. I finished following the tutorial and after syslinux didn't work I deleted the Linux partitions and tried to boot from my SSD which gave the error: "Reboot and Select proper Boot device ..."

To check wether or not my data was ok I changed the partition type of the 2TB harddrive to mrd and installed Win 8 onto it which worked fine. I can see all my data and I even need the Admin password of the new Windos install to access user files. Has anyone any idea, why my Windows isn't booting? Help would be apreciated.

LG n0w0rk

1

Reinstallation of Windows should fix the MBR (Master Boot Record), so it's weird it didn't happen, but you can also do it manually, check for example this guide.

Basically, you need to do the following:

  1. Boot from an installation or recovery media (CD/DVD/USB drive)
  2. Select Repair > Troubleshoot > Command line
  3. Execute the following commands:

    bootrec /FixMbr
    bootrec /FixBoot
    bootrec /ScanOs
    bootrec /RebuildBcd
    
  4. Reboot

Also, make sure that the Windows partition is set as active, check for example this guide for details (the second part How to change active partitions).

  1. Boot from an installation or recovery media (CD/DVD/USB drive)
  2. Select Repair > Troubleshoot > Command line
  3. Run DiskPart
  4. Execute List Disk and find the disk containing the installed Windows system
  5. Execute Select Disk x where x is the disk from the previous step
  6. Execute List Partition and find the partition containing the installed Windows system
  7. Execute Select Partition x where x is the partition from the previous step
  8. Execute Active
  9. Reboot
| improve this answer | |
  • I get the error that 0 Windows-Installations have been found. I saw an Partition labeled Restoration-Partition – N0W0RK Apr 28 '17 at 16:23
  • When did you get that error, what did you do before? The Restoration-Partition labeled partition is most probably a recovery partition, it should be quite small, it's not what you want to boot into I would say. – David Ferenczy Rogožan Apr 28 '17 at 16:27
  • after bootrec/ScanOs and bootrec/RebuildBcd but now i at least het an error screen on boot. I try using my Win 8 installation disk because i downloaded win 10 ISO on another computer, but it wont work. – N0W0RK Apr 28 '17 at 17:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.