1

I have installed a rather long, about 20m, cat5e cable linking my VDSL modem to the rest of the network, and used female, surface-mounted RJ45 connectors also rated for cat5e. The reason is I have a rather bad VDSL signal, and bad internal phone wiring, so wanted to keep the phone cable as short as possible.

Shorter (1m) cat5e patch cables (male-male) complete the circuit at its ends. I added a 5-port 1Gbps D-Link Green switch right next to the modem, and linked the switch to the two other switches, all 1Gbps. The modem is rated for 100Mbps on the LAN ports, so I should get 1Gbps between LAN computers, and 100Mbps toward the Internet. That's OK, my Internet connection is the fastest available at 50Mbps.

I plugged a LaCie Cloudbox to the first switch, and it correctly negotiated 1Gbps speed (Green light on the D-Link switch).

However, the long cat5e cable (female-female) between the first and second Ethernet switches only gives 100Mbps (Orange light on the D-Link), meaning there's a bottleneck between the LaCie Cloudbox and the rest of the devices.

Suspecting either a bad second switch or faulty cables (most of them are used), I tried different cable combinations at each end, and connected a known-good computer at the other end of the long Ethernet cable, still gives 100Mbps.

What could be the reason why I don't get 1Gbps between all the switches?

EDIT FOR CLARITY: Thanks all,

the first switch is D-Link DGS-1005G, revision B1, the second switch is a generic Chinese based on some Realtek chip, the third is another generic Chinese, same kind of chip. Couldn't read the part number as they stuck a heatsink on it.

The female-female cable is 4 pairs, solid core. By the way, it comes from a 1000 feet spool fed from a box, the same kind professional installers use. I wired it following T568B color code.

I switched the first, original cat5e patch cable (4-pair, yellow, wired according to T568B, factory molded) from the D-Link switch to the female plug of the 20m cable with another cat5e patch cable approximately the same length (4-pair, grey, T568B, factory-molded), then another 2m cat5e patch cable (white, T568B) I made by hand from the same length as the 20m cable. I know it's not recommended to use solid-core for patch cable, but I use it as a back-up cable that only sees occasional usage. This cable is known-good for Gbps speed (tested both at home and in university).

No combination succeeded.

Then I switched the other end of the 20m cable with the same 2 cables listed above, still no success (Italics for easier reference in replies).

I know the LaCie Cloudbox can't max out 1Gbps LAN from a single hard drive, just that it negotiates such speed.

5
  • 2
    Please show models of D-Link switches. And how many pairs does the cable have? – Khirgiy Mikhail Apr 30 '17 at 4:30
  • Can you verify the 20m cable is solid, not stranded patch? With patch cable, you will find the signal will degrade quicker and require more retransmissions, but the limit for solid is 100m (300ft). – CConard96 Apr 30 '17 at 14:03
  • You say you tried different cable combinations. What exactly did you try? Why not just get a higher-quality 20m cable? – Daniel B Apr 30 '17 at 19:52
  • Can you confirm that both ends were wired the exact same way? Can you tell us the pins-to-pairs mapping you used on each end? That's the most likely explanation, that or a pin that just isn't making contact. – David Schwartz May 1 '17 at 6:42
  • Try to use 40m cable or above. Because dlink use "green power" (less power) on cables which are shorter then 20m. – Khirgiy Mikhail May 1 '17 at 17:11
2

I would get a cable tester and double check the cable wiring - I posit that one of the wires is not punched down/crimped properly. Gigabit connectivity requires all 4 pairs work fine, while 100 megabit can run fine off 2 pairs. (I read your post, but it does not seem to me that you have tested the 20 meter cable on other hardware - that might be something else you wish to try)

I doubt it would be the case, but I guess it could also be an issue relating to crimping of the cable. You have not made it clear, but seem to imply you have a male connector on 1 end and female on the other - my understanding is that solid core is generally female to female, stranded core is male to male - and the connectors are designed differently with this in mind. I'd have expected this to reduce throughput but not stop negotiation at gigabit though.

2
  • Thanks. I ordered a simple cable tester and it turns out wire number 4 (solid blue) was not properly crimped, on both female jacks. I guess I was careless at the time I made this cable. Best $5 I spent this week! – P. N. May 12 '17 at 22:09
  • Worth noting that a cheap cable tester can indicate good wiring however if you have used RJ45 connectors meant for stranded wire on solid, the crimp will be intermittent and substandard as the straight teeth will only be sitting on the top and not pushed each side of the wire. The teeth are offset for single strand solid wire. You should ideally use a cable Verifier which is a lot more expensive to diagnose issues. – Ninga Mar 1 '19 at 15:26
-1

Check the Ethernet adapter in Windows device manager. It should be set to Auto Negotiate. You could try forcing it to Gigabit only speeds for testing purposes.

Also make sure your Cloudbox port is enabled for Gigabit.

Also try a different arrangement of switches or cables to identify the bottleneck through the process of elimination.

If you don't have a fancy tester there is a nice program called LanTestLite you can try.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.