1

There was a problem during installing some packages for the printer server on debian.

I used the commands:

apt-get install task-print-server

apt-get install cups

And I got following errors:

Do you want to continue? [Y / n] j
Setting up ssl-cert (1.0.35) ...
Groupadd: Error writing changes to / etc / group
Addgroup: / usr / sbin / groupadd -g 122 ssl-cert returned error code 10. > Programs.
Dpkg: Error processing package ssl-cert (--configure):
Subprocess installed post-installation script returned the error value of 1
Dpkg: Dependency problems prevent configuration of cups daemon:
Cups-daemon depends on ssl-cert (> = 1.0.11); but:
 Package ssl-cert is not configured yet.

Dpkg: Error processing the package cups-daemon (--configure):
Dependency problems - remains unconfigured
Dpkg: dependency problems prevent configuration of cups-core-drivers:
Cups-core-drivers depends on cups-daemon (> = 1.7.5-11 + deb8u1); but:
 Package cups-daemon is not yet configured.

Dpkg: Error processing package cups-core-drivers (--configure):
Dependency problems - remains unconfigured
Set up cups-client (1.7.5-11 + deb8u1) ...
Group "lpadmin" (GID 122) ...
Groupadd: Error writing changes to / etc / group
Addgroup: / usr / sbin / groupadd -g 122 lpadmin returned error code 10.  > > Programs.
Dpkg: Error processing package cups-client (--configure):
 Subprocess installed post-installation script returned the error value of 1
Dpkg: dependency problems prevent configuration of cups:
Cups depends on cups-core-drivers (> = 1.7.5-11 + deb8u1); but:
 Package cups-core-drivers is not configured yet.
Cups depends on cups-daemon (> = 1.7.5-11 + deb8u1); but:
 Package cups-daemon is not yet configured.
Cups depends on cups-client (> = 1.7.5-11 + deb8u1); but:
 Package cups-client is not configured yet.

Dpkg: Error processing the package cups (--configure):
Dependency problems - remains unconfigured
Dpkg: dependency problems prevent printer-driver-hpcups configuration:
Printer-driver-hpcups depends on cups (> = 1.4.0) Cupsddk; but:
 Package cups is not configured yet.
 Package cupsddk is not installed.
Printer-driver-hpcups depends on cups; but:
 Package cups is not configured yet.

Dpkg: Error processing package printer-driver-hpcups (--configure):
Dependency problems - remains unconfigured
Dpkg: dependency problems prevent hplip configuration:
Hplip depends on printer-driver-hpcups (= 3.14.6-1 + deb8u1); but:
 Package printer-driver-hpcups is not configured yet.
Hplip depends on cups (> = 1.1.20); but:
 Package cups is not configured yet.

Dpkg: Error processing package hplip (--configure):
Dependency problems - remains unconfigured
Dpkg: dependency problems prevent printer-driver-postscript-hp 
configuration:
Printer-driver-postscript-hp depends on hplip (> = 3.14.6-1 + deb8u1); but:
 Package hplip is not configured yet.

Dpkg: Error processing package printer-driver-postscript-hp (--configure):
Dependency problems - remains unconfigured
Dpkg: dependency problems prevent printer-driver-goodprint configuration:
Printer-driver-goodprint depends on cups (> = 1.3.0); but:
 Package cups is not configured yet.
Printer-driver-goodprint depends on cups-client (> = 1.3.0); but:
 Package cups-client is not configured yet.

Dpkg: Failed to edit package-printer-driver-goodprint (--configure):
Dependency problems - remains unconfigured
Dpkg: dependency problems prevent printer-driver-splix configuration:
Printer-driver-splix depends on cups (> = 1.5.0-3 ~); but:
 Package cups is not configured yet.
Printer-driver-splix depends on cups-client; but:
 Package cups-client is not configured yet.

Dpkg: Failed to edit package-printer-driver-splix (--configure):
Dependency problems - remains unconfigured
Dpkg: dependency problems prevent configuration of cups-bsd:
Cups-bsd depends on cups-client (= 1.7.5-11 + deb8u1); but:
 Package cups-client is not configured yet.

Dpkg: Error processing package cups-bsd (--configure):
Dependency problems - remains unconfigured
Dpkg: dependency problems prevent configuration of task-print-server:
Task-print-server depends on cups; but:
 Package cups is not configured yet.
Task-print-server depends on cups-client; but:
 Package cups-client is not configured yet.
Task-print-server depends on cups-bsd; but:
 Package cups-bsd is not configured yet.

Dpkg: Failed to edit package task-print-server (--configure):
Dependency problems - remains unconfigured
Errors occurred while editing: ssl-cert
cups-daemon
cups-core-drivers
cups-client
cups
printer-driver-hpcups
hplip
printer-driver-postscript-hp
printer-driver-gutenprint
printer-driver-splix
cups-bsd
task-print-server
E: Sub-process /usr/bin/dpkg returned an error code (1)

I don't know if this caused to not find the printer automatically. At least I could get the cups server running and tried to add a new printer, however it asks me for an url of the printer. I just typed ipp:// and I could follow other steps to install the right printer driver too. But when I want to print the system says url missing or wrong.

Is there a way to find this url ?

Ouput of stat:

root@debian:/# stat /etc/group
Datei: „/etc/group“
Size: 890 Blocks: 8 EA Block: 4096 regular file
Device: 801h / 2049d Inode: 263431 Shortcuts: 1
Access: (0644 / -rw -r - r--) Uid: (0 / root) Gid: (0 / root)
Access: 2017-04-30 17: 38: 18.204676461 +0200
Modified: 2016-09-23 14: 51: 00.519083038 +0200
Changed: 2016-09-23 14: 51: 00.519083038 +0200
Birth: -

Root @ debian: / # stat / etc / passwd
File: "/ etc / passwd"
Size: 2119 Blocks: 8 EA Block: 4096 regular file
Device: 801h / 2049d Inode: 263492 Shortcuts: 1
Access: (0644 / -rw -r - r--) Uid: (0 / root) Gid: (0 / root)
Access: 2017-05-01 01: 17: 01.237979036 +0200
Modified: 2017-04-03 00: 27: 01.880558770 +0200
Changed: 2017-04-03 00: 27: 01.880558770 +0200
Birth: -

Output of lsattr:

root@debian:/# lsattr /etc/passwd
-------------e-- /etc/passwd

root@debian:/# lsattr /etc/group
-------------e-- /etc/group
8
  • Why do you expect it to find your printer automatically? How is the printer connected to your PC? What make and model (please be precise) is the printer?
    – Daniel B
    Commented Apr 30, 2017 at 21:46
  • Yes, sorry, the printer is connected via usb2.0 highspeed, it is an Epson Stylus SX200, on a vm with Debian 3.16.0-4-686-pae.
    – Tech-IO
    Commented May 1, 2017 at 4:11
  • Ah, alright. So it should indeed be detected automatically. I don’t have a Linux-compatible printer available, so I cannot provide instructions on that. Could you perhaps clarify what exactly went wrong when you installed CUPS? How did you install it? The exact command may still be available in history.
    – Daniel B
    Commented May 1, 2017 at 8:52
  • Hello, thanks for your answers, I updated my question, with the requested infos.
    – Tech-IO
    Commented May 1, 2017 at 12:43
  • Hm. Please provide the output of stat /etc/passwd /etc/group and lsattr /etc/passwd /etc/group. Verify that whatever partition /etc is on isn’t mounted read-only. Do you have AppArmor, SELinux or something similar active? Are any other security measures in place that would prevent useradd or groupapp from working?
    – Daniel B
    Commented May 1, 2017 at 13:06

0

You must log in to answer this question.

Browse other questions tagged .