1

I have followed these instructions for installing tftpd64 on my 64 bit Windows 10 OS:

http://www.tricksguide.com/how-to-setup-a-tftp-server-tftpd32-windows.html#comment-84949

When I do this I get an error when TFTP restarts. It says:

Bind error 10013 An attempt was made to access a socket in a way forbidden by its access permissions. 69.254.119.202.

It doesn't seem to matter which IP I choose from the "Bind TFTP to this address" dropdown in the Settings panel. I still get the error. An error also appears in the TFTP log viewer that says:

Error : socket returns 10022 [02/05 21:40:28:822]

enter image description here

How do I resolve this error?

4 Answers 4

0

You surely have permission issues then the bind fails with the mentioned error. Try solving the permission thing or try not binding the IP address; that means TFTP will be listening from "all" the available NICs.

You can also try Serva; better TFTP server.

0

Bind error 10013 indicates that the port is in use. I had this same issue today and I found that while the UDP port 69 was not in use, the data ports were. Just like with FTP, TFTP negotiates ephemeral ports to use for data transfer after the connection is made on UDP 69. Jounin's tftpd64.exe software allows you to select a port or range of ports to be used for data where it says "local ports pool" in the settings. Instead of leaving this blank, choose a port you know to be not in use (e.g. 70). Once I determined that UDP 69 was not in use on my machine, I set the local ports pool to 70-71 (I had to specify a range; a single port would not be saved in the .ini file), restarted TFTPd, and I no longer got the "Bind error 10013" message. So, if you find that your UDP port 69 is not in use, but it still doesn't work, try setting the local ports pool.

-1

I have the same issue and found that port 69(TFTP) was being user elsewhere. I simply used port 70(settings\TFTP) Problem gone

1
-1

i fixed this issu by editing "tftpd32.ini" file.

  1. Go to TFTPD installation folder in my case (C:"Program Files"\Tftpd64)
  2. Edit "Tftpd32.ini" file by notepad
  3. Change TftpPort=69" to "TftpPort=70"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.