0

I am running Linux Mint 18.1 Cinnamon 64-bit (Cinnamon version 3.2.7) in VirtualBox 5.1.22 r115126 (Qt5.6.2) with Guest Additions 5.1.22 r115126.

Allocated to the VM:

  • 2560 MB base memory
  • (2) Intel Core i7-5700HQ CPU @ 2.70GHz
  • 56 GB storage.

I/O APIC, PAE/NX, VT-x/AMD-V, Nested Merging are all enabled. 3D and 2D acceleration are disabled.

The host is a Windows 10 with 12 GB memory and an Nvidia GTX960m graphics card but VirtualBox uses its own graphics adapter for some reason.

Although the correct version of Guest Additions is installed, the VM boots in software rendering mode. If I turn on 3D Acceleration before boot, this error message does not appear but the VM messes up and crashes with a memory error when using programs like Chromium or Atom. When in software rendering mode, the VM becomes unbearably slow and uses 100% CPU.

2

If anyone is stumbling upon this, I found some information for my question.

It seems to be an ongoing problem with VirtualBox when 3D Acceleration is enabled. For me, Atom always triggered the crash in Linux Mint and searching for that issue with Atom brought me to down a deeper rabbit hole. Here are some more sources on the bug.

It seems the solution is to either turn off 3D Acceleration in VirtualBox or downgrade Guest Additions to version 5.0.16.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.