0

I was trying to set up always in my local machine.  As a part of this, I need to install a domain controller and change the IPv4 address for a Windows Server 2012 virtual machine, which is hosted in VMware.

Following a tutorial, I was told to change the below settings:

enter image description here

where "Default gateway" should point to my Windows default gateway.

Below is the IPConfig for my Windows machine:

Windows IP Configuration


Ethernet adapter Ethernet:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . : 

Wireless LAN adapter Wi-Fi:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . : 

Wireless LAN adapter Local Area Connection* 14:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . : 

Ethernet adapter VMware Network Adapter VMnet1:

   Connection-specific DNS Suffix  . : 
   Link-local IPv6 Address . . . . . : fe80::9040:ccfe:9710:cd67%20
   IPv4 Address. . . . . . . . . . . : 192.168.116.1
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 

Ethernet adapter VMware Network Adapter VMnet8:

   Connection-specific DNS Suffix  . : 
   Link-local IPv6 Address . . . . . : fe80::28bc:42a0:8e7f:8105%7
   IPv4 Address. . . . . . . . . . . : 192.168.153.1
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 

Wireless LAN adapter Wi-Fi 2:

   Connection-specific DNS Suffix  . : 
   Link-local IPv6 Address . . . . . : fe80::9d2e:967e:ea6e:b2a8%13
   IPv4 Address. . . . . . . . . . . : 192.168.43.198
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.43.1

Tunnel adapter Local Area Connection* 12:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . : 

But it seems this is not correct, since I can't see any Internet connection on Windows Server 2012, even after restart.

How do I set up the network on a Windows Server virtual machine that is hosted on VMWARE?

  • You should be assigning the VMware Adapter an address within the 192.168.43.1/24 subnet. – Ramhound May 4 '17 at 23:34
2

According to your ipconfig there are two vmware networks 192.168.116 and 192.168.153. You configured your server that is running in VMWare to your local network 192.168.43.

Make sure that you configured the VMWare host to run in network bridge mode to be able to connect to the VMWare host from your local network.

  • Can you plz elaborate on this – TheGameiswar May 5 '17 at 2:48
  • ipnumbers are part network-id and part host-id. To be able to communicate, all hosts in a network must use the network-id that is assigned to the network. According to your ipconfig, you have 3 different networks on your machine: 1 local network and two VMWare networks. If you assign an ipnumber to your VMWare machine that has the network-id of the local network, then you have to connect that machine to the local network. This can be done by setting 'bridge mode' on the VMWare machine. – anneb May 7 '17 at 15:27
1

What kind of configuration do you have set on your VMWare Network Adapter? Try to use NAT for the virtual machine server. Using (NAT) the virtual machine shares the IP address of the Windows on the external network. The Windows provides network address translation (NAT)for network traffic from the virtual machine. OR use autodetect (Bridged) This will allow the virtual machine to appeared as an additional machine on the same physical connection as your Windows.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.