0

My system is linux slackware 13.0 with firefox 17.0.1 installed as the newest web browser, however, a few pages such as paypal and google accounts are not loading correctly or not at all.

Rather than replacing my whole computer, is there a way I can get a newer version of firefox than 17.0.1 without receiving any library errors when attempting to execute firefox from the command line?

I mean if I can get a later version to work as a result of installing an extra library or two on my system, I'd go for that solution instead.

I searched google, but others have similar problems with various library errors when trying certain versions of firefox.

If firefox isn't the answer, then is there another web browser out there that would fit slackware 13 that can also load new fisher-price looking web pages properly?

  • 2
    You will have to install or compile the newer library files to accomplish this – Ramhound May 5 '17 at 3:27
  • I'm willing to if I know exactly the ones to install, and the error messages alone aren't descriptive enough in determining all of the libraries required to update/install. – Mike -- No longer here May 5 '17 at 3:51
  • 1
    17.0.1 is going on 5 yrs old, 36 versions behind the current one. It's amazing that you don't have problems on most web sites, and it probably has security issues. Your Slackware is still supported, but it's going on 8 yrs old. Is there a reason you haven't considered bringing the system more up-to-date? What constraints do you have on a solution? What hardware resources? – fixer1234 May 5 '17 at 5:40
  • If your system supports a virtual machine, you could run a newer system with a newer browser in a VM – Xen2050 May 5 '17 at 7:11
  • @Mike The error messages should tell you exactly what versions of which library files Firefox uses – Ramhound May 5 '17 at 11:47
2

You cannot keep your cake and eat it too. Firefox has a set of system requirements that you must satisfy before updating it:

Firefox will not run at all without the following libraries or packages:

  • GTK+ 3.4 or higher
  • GLib 2.22 or higher
  • Pango 1.14 or higher
  • X.Org 1.0 or higher (1.7 or higher is recommended)
  • libstdc++ 4.6.1 or higher

For optimal functionality, we recommend the following libraries or packages:

  • NetworkManager 0.7 or higher
  • DBus 1.0 or higher
  • GNOME 2.16 or higher
  • PulseAudio

Other web browsers also have their own comparable requirements.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.