1

I am working on redhat linux system and it is not detecting Solid state disk(not working as hot plugging) if i insert it after boot up. If the SSD's are present before booting up of system then those disk are hot plugging(I can remove and insert it again and again and it detects automatically). So can anyone help me , do i have to change any configuration file or is it a driver issue. It use SCSI bus.

  • Have you tried rescanning the scsi bus ? echo "- - -" > /sys/class/scsi_host/<host_number>/scan – davidgo May 5 '17 at 7:43
  • yes i tried it but it does not work. Also the /sys/class/scsi_host/<host_number>/scan file does not have permission to write in it and its permission cant be changed even by root – manoj May 5 '17 at 7:50
  • In that case have you tried temporarily disabling selinux? – davidgo May 5 '17 at 7:56
  • Welcome to Super User! All information about your problem should be included in the question. Answer posts are reserved for solutions. You can freely edit your own posts but for your protection, this must be done under the original user account. It looks like you have created a second account, which will also interfere with your ability to comment within your thread and to accept an answer. See Merge my accounts to get your accounts merged, which will solve the problem. You may need to register an account to do that. – fixer1234 May 5 '17 at 8:22
  • I checked the status, SELinux is already disabled :( Also if the disk was present during bootup and after bootup if i remove it and insert it back, the logs are printed in /var/log/messages but as i said earlier in my question if i insert it afterwards (i.e, while booting if drive was empty) there are no logs printed after inserting. – manoj May 5 '17 at 9:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.