9

I have Window 10 Home Edition running in LENOVO-Y700, I once restored it from the recovery drive but accidentally, I installed it with Danish language. After that I managed to change the display language to English. But recently an update has been installed and the display language returned to Danish. I tried to change it like I did in the first time but it returns to Danish each time. I tried the recommended ways change the language but the problem persists.

How do I persistently change the Display Language on Windows 10 Home?

[picture change the windows lang

  • do you use Home or Home Single Language? Post a picture of running winver.exe – magicandre1981 May 7 '17 at 16:57
  • No it is not Home Single Language because I was able to change it to English , But when an update was installed it returned back to Danish, In addition I have the option of changing the language but the problem is that it doesn't apply. – Smn Dvp May 7 '17 at 18:14
  • I had the same issue. The internet stuff worked for me with English (GB) for some reason, but not with English (US). – user1111929 Aug 13 '17 at 23:37
3

The only thing that worked for me was installing the language package manually:

https://www.itechtics.com/windows-10-version-1709-language-packs-direct-download-links/ (installation instructions underneath the download links)

After the language pack is installed:

  1. Region and language settings

  2. Additional date, time & regional settings (Control Panel\Clock, Language, and Region)

  3. Language
  4. "Options" next to the language you want to select
  5. "Override" / "Change override" and choose the language
  6. Apply language settings to the welcome screen, system accounts, and new user accounts
  7. Copy Settings
  8. Check "Welcome screen and system accounts" and "New User Accounts" if you desire.
| improve this answer | |
  • 1
    It might be worth including the download links (for eg Danish/English/other ones you feel are relevant here) in your answer – bertieb Mar 27 '18 at 17:37
  • Actually I have solved the problem by reinstalling windows and selecting English as the system language. – Smn Dvp Mar 27 '18 at 22:29
  • @bertieb Agree, but I'd have to keep them up to date, as they would change with every build of Windows. The site I mentioned adds a link to downloads for the new build if it is released. – discy Mar 28 '18 at 10:44
  • Unfortunately, if you still had that menu in March '18... then you were still running on an early 1709 build... 1709 was the first release to ditch "Clock, Language, Region" for good :-( – Hicsy Aug 2 '19 at 3:22
2

If you are using Windows 10 with local account, press Windows + I to access the Settings application.

  • Next, choose Time & language and then Region & language.

  • After that, select Add a language and then add the language you want to change to. I think it's English, right :). So just choose it from the list.

  • Next step, set it as default.

  • Press Ctrl + X and choose Control Panel

  • Choose Language and then Add a language.

  • Next, select Advanced settings -> Apply language settings to the Welcome screen, system accounts, and new user accounts.

  • On the Administrative tab, under the "Welcome screen and new user accounts", click the Copy settings button.

  • Check the Welcome screen and system accounts and the New user accounts options.

  • Click OK

  • Click OK again.

Reboot your computer and upon restart, you should see the new default language globally set through the operating system.

For step by step guide with images, read this article.

| improve this answer | |
  • thanks for your answer. However, I mentionned above that I tried most of the ways that i found in the internet, but the problem seems to be more complicated. Because when I try to copy the setting and I hit ok it returns back to danish like it is shown in the piicture above . I also tried to change it from the registry following this tutorial winaero.com/blog/… but when I reboot the language returns to its initial value :( I am disoponted because I don't want to wipe my computer. – Smn Dvp May 7 '17 at 18:03
  • Tried to change it from Safe Mode? – KevinD May 8 '17 at 4:26
  • I've just tried that but the same behaviour. – Smn Dvp May 8 '17 at 8:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.