How can I change the default behaviour of the Fn key?

Basically I want it to be turned on all the time.

Is there something there for Ubuntu? None of the solutions (hardware) works for me, neither does my BIOS allow me to toggle it.

I did try all the combinations given (Fn+ESC, Fn+NumLock, Fn+F1+F12 ), but none worked.

Apparently it depends on laptop model, so mine is Lenovo G50-45

  • Fn + scroll lock did the trick for me on a Fujitsu notebook. I believe it depends on the brand of your device. – Alex May 7 '17 at 15:54
  • thanks @Alex, I don't actually have scroll lock on my keyboard (or I'm simply blind). I updated my question with laptop model :) But I think I'd still prefer some sort of a software solution (like something that would simply hook to system event and set fn as pressed?) – user693842 May 8 '17 at 7:37

Fn+Esc worked on my Lenovo ThinkPad E550. Thanks for the hint.

Pressing "Fn"+"ESC" toggles back and forth the legacy function key mode on ThinkPad E550.

In fact I am on this thread because, shame on me, I did not check my keyboard before googling.

On the "ESC" key there is a tiny "FnLk". That might be a good hints for others.

I run UBUNTU 16.04 and it works, but I think the function is implemented at bios level and should work regardless of the operating system in use.


My Lenovo Ideapad laptop had this option in BIOS settings.

-Under "Configurations" tab, set "Hotkey mode" to "Disabled"

To open BIOS settings, press Fn+F2 if you haven't changed this option before. Or uses "Novo" button, if exists.

Here's a link to the official site: Change function key mode

If it isn't showing, maybe try updating the BIOS


If you're using DELL laptop with Windows OS then pressing Fn+Num lock key would disable the function key issue.

Num lock key is nothing but the Home key, by pressing Fn+Home key will act as releasing the Fn Numlock issue.

  • 1
    The question indicates the laptop is Lenovo. Please read questions carefully to make sure the answers you supply are relevant. – music2myear Apr 30 '18 at 15:50
  • @music2myear as a DELL user I find this answer of utmost importance. It's something usual here in SO to have this sort of side answers as users often land from search engines – ruizpauker Apr 23 at 17:36

If you have Lenovo Vantage installed, use it. There is an option to define that behavior: 1. Run Lenovo Vantage -> Hardware Settings 2. Input -> Function Keys

Screenshot LenovoVantage

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.