0

im having serious issues with my computer. When i boot on safeboot i can connect to the internet. But after a normal boot i cannot.

Note that on normal mode i can ping google.com but cannot go on internet nor curl. I cannot talk to a server running on localhost either !

Im on El Capitan 10.11.6. I think i connected to a bad wifi in a hotel but apart from that i didnt change any configuration files myself.

I read that after safeboot things should work again on my session but... no. Any suggestion?

Note that i have tried to kill mDNSResponder too. Thanks

0

Seems some of your Wifi settings are out of whack.
(And booting in safeboot mode won't repair that. Safeboot uses it's own independent settings but will not change settings for the normal opeartion.)

Go to System Preferences, Network settings. Select the Wifi adapter on the left-hand side. You should see a button on the top-right that says "Turn Wifi OFF". Do that first.

Then press the "Advanced..." button on the lower-right hand side.
You will see a new windows with multiple tabs. Go to the TCP/IP tab and make sure that "Configure IPv4" is set to "Using DHCP" and that "Configure IPv6" is set to "Automatically".

Now go to the "DNS" tab and remove EVERY DNS entry listed there. If you needed anything to be placed there you would have known about it. Normally this should be empty.

Click OK to get back to the regular network preferences screen and switch Wifi back to "On".

You have now reset most of the Wifi settings back to defaults. Hopefully that has cleared the problem settings.

| improve this answer | |
  • Thanks. Actually everything was alright unfortunately. Any other idea? – Thomas May 7 '17 at 16:26
  • Check proxy settings. You should not be using one. (I have encountered some hotel networks that forced you into using their proxy and the proxy setting remained in place later.) – Tonny May 7 '17 at 16:28
  • No proxy either – Thomas May 7 '17 at 16:30
  • If it can help on both normal and safeboot when wifi is on i see a ipv4 address/subnet mask etc and ipv6 has 4 addresses too. DNS has a ipv4 and an ipv6 address. All values are the same in both modes – Thomas May 7 '17 at 16:47
  • I also removed all items in Library/LaunchDaemons , ...Agents and startup items and in ~/Library/... Still no luck – Thomas May 7 '17 at 17:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.