8

Google Chrome throws up a modal dialog box once in a while. This is the box put up by js's alert() function.

Installing an extension also puts it up. So does this very Stack Exchange website if I hit "back" while writing a post like this one.

It's modal, so the browser's UI (the whole browser window, not just the current tab) is frozen while the dialog box is up.

My problem: the dialog box is off screen for me. I can hit <esc> to dismiss it. I can hit <tab> <enter> to accept it. But I can't see it. The dialog box isn't represented in the Windows taskbar as a separate window, so I can't do the old Move trick to move it back onscreen.

I've tried obvious stuff like reinstalling the browser.

How do I get this dialog box to be visible again?

  • Try to temporarily change the monitor's resolution to another value and Apply. Questions: (1) Do you have more than one monitor? (2) Did you try the old Move trick by doing ALT+Space/M and then Enter? (try also alt-tab to position to Chrome) – harrymc May 16 '17 at 12:16
  • Is it even possible to move it out of the window? Plus does it spawn there or is it somehow shifted? – Varad Mahashabde May 17 '17 at 11:37
7
+25

If the window is active, you can press ALT+SPACE followed by m. This will allow you to move the window with the arrow keys.

  • This solution worked for me when I had a similar problem with Visual Studio 2019 opening dialog windows off-screen. – Paul Russell Nov 7 '19 at 12:07
1

Right-click the task bar and select 'cascade windows' or 'show windows stacked'. That re-arranges all the windows, including the modal dialog that this SO site created while I was writing this post :)

1

Try to temporarily change the monitor's resolution to another value and do Apply.

If any problem, try also using alt+Tab to position to Chrome.

1

The answer to this question appeared here on Stack Overflow.

https://stackoverflow.com/questions/43022839/chrome-modal-dialogs-dont-appear-locks-up-window

As it happens, disabling hardware acceleration for the browser did the trick. Clear the check from the checkbox at Settings / Advanced Settings / System / Use Hardware Acceleration.

  • does not work in all cases – Drako Nov 9 '18 at 13:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.