21

I'm using Thunderbird's Lightning addon to manage my calendars. I've been running into an issue where certain calendar events simply refuse to be dismissed for several days. They usually end up going away after a while but it's been over a week for the latest instance of this and I can't get it to go away.

The only pattern I can see in this is that it seems to occur with reoccurring events but other than that it seems entirely random.

My process is as follows

  1. I click "Dismiss"

  2. A window appears stating "This item has recently been changed on the server. Submitting your changes will overwrite the changes made on the server.

  3. If I click "Discard my changes and reload", the reminder immediately appears. If I click "Submit my changes anyway" the reminder appears in another 10 minutes.

I've looked in the error log in thunderbird and I found the following that seems relevant:

Timestamp: 05/08/2017 10:09:50 AM
Error: [calGoogleCalendar] Modifying item Water Polo Practice 
failed:2152334338: [object Object]
Source File: 
file:///home/sam/.thunderbird/g9dn5ln5.default/extensions/%7Ba62ef8ec-5fdc-40c2-873c-223b8a6925cc%7D/components/calGoogleCalendar.js
Line: 532

Timestamp: 05/08/2017 10:09:46 AM
Error: [calCachedCalendar] replay action failed: null, uri=googleapi://xxx.xxx@gmail.com/?calendar=xxx.xxx%40gmail.com, result=[object Object], op=[xpconnect wrapped calIOperation]
Source File: file:///home/sam/.thunderbird/g9dn5ln5.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calCachedCalendar.js
Line: 327

Timestamp: 05/08/2017 10:05:56 AM
Error: [calCachedCalendar] replay action failed: null, uri=googleapi://xxx.xxx@gmail.com/?calendar=xxx.xxx%40gmail.com, result=[object Object], op=[xpconnect wrapped calIOperation]
Source File: file:///home/sam/.thunderbird/g9dn5ln5.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calCachedCalendar.js
Line: 327

Timestamp: 05/08/2017 09:52:45 AM
Error: [calGoogleCalendar] Modifying item Water Polo Practice failed:2152334338: [object Object]
Source File: file:///home/sam/.thunderbird/g9dn5ln5.default/extensions/%7Ba62ef8ec-5fdc-40c2-873c-223b8a6925cc%7D/components/calGoogleCalendar.js
Line: 532

Timestamp: 05/08/2017 09:52:40 AM
Error: [calCachedCalendar] replay action failed: null, uri=googleapi://xxx.xxx@gmail.com/?calendar=pd46t6fbk0o8h30jev2ttavqjo%40group.calendar.google.com, result=[object Object], op=[xpconnect wrapped calIOperation]
Source File: file:///home/sam/.thunderbird/g9dn5ln5.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calCachedCalendar.js
Line: 327

Timestamp: 05/08/2017 09:52:40 AM
Error: [calCachedCalendar] replay action failed: null, uri=googleapi://xxx.xxx@gmail.com/?calendar=xxx.xxx%40gmail.com, result=[object Object], op=[xpconnect wrapped calIOperation]
Source File: file:///home/sam/.thunderbird/g9dn5ln5.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calCachedCalendar.js
Line: 327

Timestamp: 05/08/2017 09:52:40 AM
Error: [calCachedCalendar] replay action failed: null, uri=googleapi://xxx.xxx@gmail.com/?calendar=ghpl0uj6sb0aibu2u2ungqrvjs%40group.calendar.google.com, result=[object Object], op=[xpconnect wrapped calIOperation]
Source File: file:///home/sam/.thunderbird/g9dn5ln5.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calCachedCalendar.js
Line: 327

Timestamp: 05/08/2017 09:52:40 AM
Error: [calCachedCalendar] replay action failed: null, uri=googleapi://xxx.xxx@gmail.com/?calendar=rj65n1laasohf35e628d7869lvi04stt%40import.calendar.google.com, result=[object Object], op=[xpconnect wrapped calIOperation]
Source File: file:///home/sam/.thunderbird/g9dn5ln5.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calCachedCalendar.js
Line: 327

Timestamp: 05/08/2017 09:52:40 AM
Error: [calCachedCalendar] replay action failed: null, uri=googleapi://xxx.xxx@gmail.com/?calendar=yyy%40gmail.com, result=[object Object], op=[xpconnect wrapped calIOperation]
Source File: file:///home/sam/.thunderbird/g9dn5ln5.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calCachedCalendar.js
Line: 327
41

Found a workaround. Turns out if I uncheck the "Show missed reminders" under Preferences>Calendar>Reminders, I don't haver this issue. I don't need to be seeing missed reminders so problem is (essentially) solved.

4
  • 2
    In some ways, I'm glad that this solution is only 1.5 years old. I've been annoyed by the problem for at least 2. Thank you! – jmorganmartin Feb 14 '19 at 21:13
  • 2
    Unfortunately this solution does not work in the latest Thunderbird version because the setting does not exist anymore. – Deckard Nov 6 '19 at 11:58
  • 2
    The setting has moved to Options > Calendar > "Show missed reminders for writable calendars". This resolved the issue for me on a calendar event I had not created. – Jason Beck Mar 13 at 0:20
  • That this setting is not default is .. odd. I OFTEN have events from others that have notifications that bug me weeks later, and I eventually end up having to delete them, because there's no other option. I can see the point in being notified of events I've missed in the last couple of hours, but why would anyone want to be annoyed by a week old event notification? – naught101 Mar 24 at 4:24
4

The case of the Exchange (EWS) calendar

One issue like this has been running for years in Mozilla support site.

I have been suffering the same problem in my Thunderbird Calendar with the corporate Exchange calendar. In my case, I had removed the recurring event from the calendar but it still was present in my Thunderbird view. I could not dismiss the reminders for the last four occurrences and I could not delete the event either in Thunderbird calendar. In the Exchange calendar (web interface) the event was not present any more.

What seems to have worked out was fiddling with the Thunderbird's calendar settings for this exchange calendar:

  • right click on the calendar in the calendar list
  • choose "Exchange (EWS) properties"
  • In the dialog go to "Folder properties" tab
  • Around the middle there is a list of users that, in my case, contains "Default" and "Anonymous" and switched between both a couple of times, watching the permissions change
  • Go to "Offline Caching" tab
  • click on "Clear offline cached data"
  • Additionally I went to "Automatic Processing" and toggled one of the checkboxes twice (effectively leaving it in it original state)
  • click "Save and Reset" button
  • the problem was solved for me.
2

The following describes how to still turn off missed reminders, after it disappeared from the options-menue:

https://dwaves.de/2020/04/15/thunderbird-calender-reminders-keep-popping-up-do-not-show-reminder-of-passed-old-missed-events/

tested with: thunderbird 68.6.0 (64-bit) on GNU Linux Debian 10

if one uses the build in calendar of thunderbird (it was called sunbird, was replaced by lightning)

go into advanced config editor: (about:config)

type: calendar.alarms.showmissed

and double-click on the entry

to change it to false

https://github.com/Ericsson/exchangecalendar/issues/546

then simply close thunderbird and restart it

2
  • Please quote the essential parts of the answer from the reference link(s), as the answer can become invalid if the linked page(s) change. – DavidPostill Nov 10 '20 at 13:48
  • It is still (or back) in the Preferences menu v78.6.0 – djo0012 Jan 7 at 14:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.