Please do not mark my question as a duplicate, as I have read the solutions to many of the same questions and despite applying them, I still have the same problem.

I have a PNY 64GB USB drive, but I cannot delete files from it or add new files to it because it is "write protected". I am using Windows 7.

What I have tried:

  1. Locating a switch, there is none.

  2. Trying to find a "Security" tab when in the properties menu of my USB drive. There isn't one.

  3. Trying to format it outright by right-clicking my USB Drive in the C: folder, and going to "format". It fails and tells me that the file is write protected.

  4. Using "Filepart" from the Command Prompt, selecting the right volume, and changing the attribute of the readonly option. Still tells me that the disk is write protected when I try to format it.

  5. Inserting the following code into a .bat file and executing it (as was suggested by a user on StackExchange to a similar question):

    reg add "HKLM\System\CurrentControlSet\Control\StorageDevicePolicies" /t Reg_dword /v WriteProtect /f /d 0

  6. Trying to edit my registry directly. The problem with this approach is that I am missing the folder required, "StorageDevicePolicies". So I created that "key" and put a DWORD value called "WriteProtect" in it, with its value data set to 0. Still the USB Drive is "write protected".

  7. Attempting to format through diskmgmt.msc, again, same problem: tells me that the file is disk protected.

  8. Downloading the HPUSBDisk-2.2.3.exe, which was supposed to be able to format my USB Drive but resulted in the same thing--cannot format because disk is write protected.

  • 2
    I've been through this, and often the simple answer is: the drive is dead. Return it under warranty if possible. Get a new one. Basically the flash controller has decided to switch to a fallback mode, and often the only way to reset this is to reset the firmware, but you never know whether it will happen again - because it usually happens when the controller detects that the storage memory is faulty.
    – Bob
    May 9, 2017 at 5:58
  • Please don't edit the answer into your question. Super User is a question and answer site and answers should be separate from questions. You can answer your own question instead.
    – DavidPostill
    May 9, 2017 at 20:33
  • That is understandable, David. Fixed.
    – Matt
    May 10, 2017 at 20:12

1 Answer 1


SOLVED: I found a link to the company's website, where software to "recover" the drive is available. If you have a similar problem with a PNY drive, please check it out, as it may spare you the headache I had.

  • That link doesn't show the software you are talking about
    – HackSlash
    Aug 3, 2021 at 16:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .