1

I have a networking question to all the experts out there.

Currently I have two TP-LINK TL-WR1043. One is connected to a cable modem and acquires a dynamic IP from the ISP. It acts as a router (192.168.0.254), DHCP server (192.168.0.100-249) and an Access Point with the SSID_1 network. I want to expand the network to the other room using a wired connection and use the builtin switch on the other TL-WR1043 and broadcast the same wireless network.I use Gargoyle on both routers at the moment but can switch to DD-WRT easily.

My question is how to accomplish that?

I don't want to use a wireless bridge since I have a wired connection between both routers.

Please see the network diagram I would like to achieve:

NETWORK DIAGRAM:

enter image description here

  • 2
    Not familar with that particular router but basically you want the 2nd "router" to function at layer 1 / layer 2 only. You should be able to turn off DHCP and the routing functions on the 2nd one so it only functions as a switch / access point. I would also make sure that the APs broadcast on different channels. – BrianC May 9 '17 at 13:55
0

The solution is quite simple if your first router is handling DHCP properly and acquiring WAN IP from cable network.

You should disable DHCP function in the second router and plug it directly via a proper cable (cat 5e will be enough for gigabit speeds) to your network.

DD-WRT is not mandatory for your usecase.

If you want proper wireless coverage and since both your routers use the b/g/n 2.4GHz band, I highly advice you to avoid overlapping by switching the first router's channel to 01, and the second to 06 or 11. (and vice-versa depending on the crowdedness in your area).

You can verify which band is used by other AP's in your area using this freeware:

Acrylic Wi-Fi Monitoring Tool

  • 1
    Also make sure to limit your DHCP range to ensure (however unlikely) that your second router's IP won't be handed out by the first router and cause a conflict which knocks every device it is handling offline. – MaQleod May 9 '17 at 22:05
0

I finally figured it out. The device in the second room was in Repeater/Bridge mode and it connected to the SSID_1 wirelessly hence the low bandwidth. After changing it to Gateway/AP mode and disabling the DHCP server it all acted as expected. It even broadcasts the SSID_1 but on a different channel.

Thanks everybody for the suggestions.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.