6

Vista is always asking me to authorize a program I have installed. Why ? How to prevent him from asking this same question all the times ?

4 Answers 4

2

Open up Control Panel, and type in user account into the search box. You'll see the link for "Turn User Account Control (UAC) on or off". Click it. Uncheck the box, and reboot your computer. You should be done with obnoxious prompts!

From lifehacker.

6
  • 4
    Bad idea. Better to be selective. Mar 16, 2010 at 21:16
  • problem with that is then UAC bothers you ALL the time with security alerts about UAC being disabled. I agree with @user26453 that it is better to be more selective.
    – studiohack
    Mar 17, 2010 at 2:14
  • as user26453 said, I'd like a selective solution like the one from user26453 if it had worked.
    – asksuperuser
    Mar 17, 2010 at 19:29
  • Correct, but is their an option to be more selective?
    – Josh K
    Mar 17, 2010 at 20:08
  • @Josh K: I do not believe so. This is, of course, an awful idea, but if one doesn't want UAC prompts, one doesn't want UAC.
    – Phoshi
    Mar 29, 2010 at 20:47
0

Try This Instead 4 Ways to Make UAC Less Annoying on Windows 7 / Vista Note: Disabling or modifying UAC is a security risk. If you want to be as secure as possible, you should likely leave things alone.

0

You can set the program to always run as administrator by:

  1. Right-click the program icon and click Properties.
  2. On the Property sheet, click the Compatibility tab.
  3. Under Privilege Level, select the Run this program as an administrator check box, and then click OK.

Update:

heavyd indicates this does not work. I cannot confirm this as I know it works on Windows 7. How about someone actually try it before downvoting and let us know via comments?

2
  • 1
    Vista will still prompt you each time your run the application.
    – heavyd
    Mar 16, 2010 at 21:21
  • Yeah Vista is really stupid he doesn't obey his master :(
    – asksuperuser
    Mar 17, 2010 at 19:28
0

You can use this software to tweak Vista's UAC : tweak-uac

You must log in to answer this question.