3

In Word 2010, typing (e.g.) Alt+1 or Alt+4 (using the Numpad) produces Unicode symbols for a smiley face or diamond symbol in the selected font – e.g. ☺ ♦ [image]

In Word 2016, these are now replaced with colourful "emoji"-like icons: Colourful emoji

cnread has offered the useful suggestion of generating the symbols by typing their Unicode points are entered (263A for 'White Smiling Face' and 2666 for 'Black Diamond Suit') and converted using Alt+X, which is a handy workaround, though it lacks the simplicity of the previous approach.

Is there an option to force Word to display the Unicode icons instead of the garish clip-art? Nothing obvious jumps out from either the settings pages, nor from the autocorrect options.

  • 1
    Are you using some Word add-in? In word without add-ins, shortcuts Alt+1 or Alt+4 are launching 1st and 4th menu item from Quick Access Toolbar. (I.e. Alt+α is activating α-th item from the toolbar.) – miroxlav May 9 '17 at 16:06
  • 1
    What happens if you type in the Unicode references (e.g., 263A for 'White Smiling Face' and 2666 for 'Black Diamond Suit'), and then press Alt+X? – cnread May 9 '17 at 16:52
  • 3
    @miroxlav he meant Alt + Numpad 1 – BrianC May 9 '17 at 16:53
  • 1
    Have you checked the Autocorrect options (File-> Options-> Mail-> button: Spelling and Autocorrect…-> button: AutoCorrect Options…)? – Ƭᴇcʜιᴇ007 May 9 '17 at 17:09
2

I also have been very frustrated with Word's auto substitutions for characters that already exist in the font I am using — coincidentally, the same font and one of the same characters u2666 as in MS609's question. Segoe UI contains the glyphs for spades, hearts, diamonds and clubs, though they are either all black or in black outline form. However, when you enter them as the Unicode characters (in my case, via AHK sending the correct character), Word substitutes the Segoe UI Emoji characters, which I definitely do not want. The XML generated in Word is as follows (for the spades character):

<w:r w:rsidR="003E3D80">
<w:rPr>
    <mc:AlternateContent>
        <mc:Choice Requires="w16se">
            <w:rFonts w:cs="Segoe UI"/>
        </mc:Choice>
        <mc:Fallback>
            <w:rFonts w:ascii="Segoe UI Emoji" w:eastAsia="Segoe UI Emoji" w:hAnsi="Segoe UI Emoji" w:cs="Segoe UI Emoji"/>
        </mc:Fallback>
    </mc:AlternateContent>
</w:rPr>
<mc:AlternateContent>
    <mc:Choice Requires="w16se">
        <w16se:symEx w16se:font="Segoe UI Emoji" w16se:char="2660"/>
    </mc:Choice>
    <mc:Fallback>
        <w:t>♠</w:t>
    </mc:Fallback>
</mc:AlternateContent>
</w:r>

One awful pile of crap for something I don't even want! The actual glyph is shown in the fourth line from the bottom, but it only appears as an emoji once Word gets hold of it.

The way that I finally resolved this problem was to use the methodology suggested above — that is, instead of sending the character, send the Unicode code point (e.g., 2660 for black spade) followed by Alt+X (SendInput 2660!x in AHK code). It's stupid that this is necessary, but yet another affirmation that Word's "smart" features are often stupid — especially when you can't shut them off. And this Alt+X way of inserting Unicode characters works only in Word, so that's a pain if you want to insert the symbols in other editors.

If you don't know about AHK (AutoHotKey), you should have a look at it — it can be extremely useful. Likewise with BabelMap and BabelPad for working with Unicode characters.

0

Yes its the formatting - to just have the normal icon use the "Sergoe UI Symbol" font. This is what it changed to on my machine - however it appears that anything other than "Sergoe UI Emoji" will show the correct font

This is not really an answer as I cant find an option to stop word automatically changing fonts - but I cant get the pictures in a comment.

With cut /paste and applying styles I get these three glyphs displayed from the one unicode point: Three characters

This following style is the original yellow emoji

enter image description here

This following style gives the expressive emoji

enter image description here

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.