I have installed Ubuntu on a PIPO X10 Pro tablet. It's a simple tablet running Intel x5-Z8350 with a DSI screen.

After booting, the display turns completely black. I am able to SSH into the machine, and try all sorts of commands to manipulate the display. I've been searching for a way to detect that the screen is black - and then force it to reboot again (which is a sucky solution).

I have no idea what's wrong. I can say that the device is using UEFI. In BIOS I have restored defaults.

dmesg|grep -i vga

[    0.394916] vgaarb: setting as boot device: PCI:0000:00:02.0
[    0.394933] vgaarb: device added: PCI:0000:00:02.0,decodes=io+mem,owns=io+mem,locks=none
[    0.394951] vgaarb: loaded
[    0.394960] vgaarb: bridge control possible 0000:00:02.0
[    1.870261] fb0: EFI VGA frame buffer device
[    3.018244] fb: switching to inteldrmfb from EFI VGA
[    3.022697] [drm] Replacing VGA console driver
[    3.099731] vgaarb: device changed decodes: PCI:0000:00:02.0,olddecodes=io+mem,decodes=io+mem:owns=io+mem

xrandr

This shows the same, regardless if the screen is working or not.

Screen 0: minimum 8 x 8, current 1920 x 1280, maximum 32767 x 32767
DSI1 connected 1920x1280+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1920x1280     60.00*+
DP1 disconnected (normal left inverted right x axis y axis)
DP2 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
HDMI2 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

Tried so far

.xinitrc

I have put these in ~/.xinitrc

  1. xset s off -dpms
  2. xset s noblank
  3. xset dpms force on; xset s reset
  4. xset dpms 0 0 0
  5. xrandr --output DSI1 --off; sleep 1; xrandr --output DSI1 --auto

Open TTY 2..6

If I open TTY 2 (Ctrl+Alt+F2) while booting, it seems the screen stays on when X starts on TTY 1.

If I don't open TTY 2 until after X has blanked my screen, the other TTYs are also black.

When I press Caps-Lock on TTY 1, while screen is blank - the LED on my keyboard changes.

When I switch to TTY 2, the Caps-Lock button does not seem to work. It works again when I switch back to TTY 1 - but the screen is still black.

  • Does rebooting the tablet cause the screen to turn on? What percentage of the time does the screen start dark, do you estimate? – music2myear May 9 '17 at 19:59
  • @music2myear It may be 50 % of the time. Now it has happened 4 times in a row. Each time after I use the reboot command. I can log into the console. It seems Xorg.0.log is from earlier today - I don't know why it is not updating. The screen is ON while booting. It turns off when X starts. – frodeborli May 9 '17 at 20:19

I seem to have solved it, with a quirky fix.

As I explained in the question, the screen does not go dark if I switch to TTY 2 during boot.

I discovered the command chvt which basically is a script that starts TTY 2, so the solution was to run chvt 2 (as root) before X starts.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.