3

I switched to Fedora 25 a few days ago for my new hardware (Ryzen 7 1800X + XFX RX580 graphics card + Gigabyte GA-AB350-gaming motherboard) since Ubuntu 17.04 fails at booting the installation media. All are running fine except the 4k video playback. So I tried to install the amdgpu-pro driver, but I am stuck at some weird dependency.

# dnf install amdgpu-pro.x86_64
Last metadata expiration check: 0:17:50 ago on Tue May  9 21:10:51 2017.
Error: nothing provides libudev.so.0()(64bit) needed by xorg-x11-drv-amdgpu-pro-1:1.2.99-414273.el6.x86_64
(try to add '--allowerasing' to command line to replace conflicting packages)

Is there anybody who has got the same problem? Which package are we supposed to install to get that libudev.so.0? I can see that I have /lib64/libudev.so.1 which is symbolically linked to /lib64/libudev.so.1.6.5, but linking that to libudev.so.0 simply doesn't work.

1

This is how i managed to install the amdgpu-pro driver on Fedora 25. Try it on your own risk.

I visited the AMD web page and downloaded the amdgpu-driver for REHL 7. Before i installed the driver i had to do some changes on my os.

First i had to install the (EPEL repo for Redhat) https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm ] which works on Fedora 25.

The second thing I had to do was to downgrade xorg drivers because the amdgpu-driver do not seems to support newer versions of xorg. And I think this is the problem you have. You need to downgrade xorg so you don't have a newer version than 1.17 installed. I suggest that you either uninstall all xorg drivers and then install the ones from Fedora 21 so you don't brake any dependencies. You can also try a simpler way with the following command: sudo dnf downgrade --allowerasing --releasever=21 xorg-x11-server-Xorg xorg-x11-server-common There is a chance that you will break some dependencies this way but the system can work anyway. Try on your own risk and base your decision on your level of knowledge.

The third and final thing I had to do was to adopt my display manager and desktop environment. The amdgpu-driver does not seem to support all options available which also was the case with the older fglrx-driver. I do not know the compatibility on all options. But on my computer I run the display manager lightdm and the desktop environment LXDE. But of course you can try to experiment with the options you want and see what works. want to use LXDE and lightdm, you can try with the following commands: sudo dnf install lightdm. Then you need to activate it: sudo systemctl disable name_of_your_current_display_manager.service and then sudo systemctl enable lightdm.service. To install LXDE you just type sudo dnf install @lxde-desktop.

Finally I am also not running the latest Linux kernel. I am not sure if this matters or not but I am running version 4.8

Finally, restart the computer and make sure that everything works. Follow the instructions on the AMD web page to install the driver. Restart the computer and hope for the best!

0

It seems that ubuntu does not start with a newer Gigabyte motherboard mismatch. (https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1671360) In the same way the AMDGPU-PRO driver does not install properly from Fedora 25, only the open source AMDGPU works. Here I had to install Fedora 26 Alpha and I used the open source AMDGPU, since I have almost the same settings as you, but an RX480.

  • 1
    You did not explain the solution to OP problem – yass May 13 '17 at 21:18
0

The libudev.so.1.N.N files should be in /usr/lib and /usr/lib64. You could make symlinks to those pointing to .0 , and then install without dependency check:

(Example: sudo ln -s /lib/x86_64-linux-gnu/libudev.so.1.6.2 /usr/lib/libudev.so.0)

rpm -Uvh --nodeps amdgpu-pro.x86_64 .

Just in case, here are the libraries known .rpms info. You should have one of the versions in the usr/lib64.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.