1

I have found that on my new XPS 13 9360 with the creators update, if I am playing back music from any source (Spotify for example), when the screen turns off after a couple of minutes, audio seems to get muted.

Anyone know where the setting is to prevent this behaviour?

  • Perhaps it’s not just turning the screen off but going to sleep mode. Does your laptop have a power indicator where you could check that? – Daniel B Jul 29 '17 at 10:46
  • It's connected standby (modern standby). If you use other store apps, such as Pdcasts Beta, audio will continue to playback when the screen turns off, Spotify and other desktop apps stop audio at that time – Eds Aug 1 '17 at 10:24
1

I encountered the same problem (also on the XPS13 interestingly). It seems to have to do with how the audio is actually played, see for example this thread that you can find by googling "windowscentral.com 253168-audio-shuts-off-when-screen-goes-sleep" (I have too little rep in this community to include more than 2 links, and this is the least relevant). One solution that was suggested was to use a screensaver that's a black screen, and set your screen to never turn off.

Another was to disable so-called 'connected standby' in your registry.

The ultimately desired solution, of course, would be for Spotify to support this connected standby mode. But the problem has apparently been around for quite a while already, so that may not happen any time soon.

In the meantime, the 'blank screen screensaver' seems the best workaround.

| improve this answer | |
  • Yes I came to the same conclusion some time ago myself. This is frustrating as the same thing happens with YouTube videos played back in Chrome, and Google are highly unlikely to make a store version of Chrome. Spotify has a store version now, but still doesn't support CS. Windows should honour traditional sleep prevention technologies, as well as support connected standby. I understand the benefits of connected standby, but most people still use a lot of desktop apps that have no store versions to replace them with – Eds Aug 1 '17 at 10:26
  • Perhaps they could just allow users to indicate 'connected standby' behavior for each program. But MS seems to have decided they want to go 'the apple way' :-) But for me, the 'blank screensaver' works - apparently, you can even configure screensavers to show the lockscreen when 'woken'. – Matherion Aug 2 '17 at 11:21
0

If your sound is coming through a monitor via HDMI, maybe when the screen shuts off the sound stops. Try telling it not to shut the monitor off when idle.

| improve this answer | |
0

I think I have another solution, but it requires a second monitor/TV... If you set it as "Duplicate screens", when you turn off both of them then sound (Spotify or another sound program) it continues on playing.

Bye!!! ;-)

| improve this answer | |
0

When my Win 7 PC goes to sleep (or put to sleep by me), I can power off the monitor (with built-in speakers). I just need to make sure that I turn on the monitor BEFORE I wake up my PC. If so, I have sound. Remote desktop wake-up will ruin this because I am not there to turn on the powered-off monitor.

Just keep in mind that anytime when the PC is NOT in the sleep mode, the monitor must be on. Otherwise, Win 7 will turn off sound because it senses no speakers. On my PC, the only way to get sound back is to restart. The "net stop audiosrv, ..." trick does not work.

Hopefully, my information will also apply to Win 10.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.