13

I recently migrated to Linux Mint and I am trying to install Windows 10 but the VirtualBox is stuck on the Windows logo. I downloaded the ISO from Microsoft. I have allotted 3.5 GB RAM to the VM.

9
  • Do you set all the required settings properly for Windows VM? Does guest VM show any error with that Windows logo?
    – Biswapriyo
    May 13 '17 at 18:33
  • Do you have UEFI enabled? I had to enable it to get Win 10 to work. Also oddly enough I had to disable secure boot on the host machine.
    – Eddie Dunn
    May 13 '17 at 18:34
  • I have the Secure Boot disabled. How can I confirm that UEFI is enabled? May 13 '17 at 18:35
  • @Biswa: I kept the Virtualbox settings as defaults and only changed the "Empty" value in "Storage" to the iso I downloaded. May 13 '17 at 18:36
  • VBoxManage modifyvm "VM name" --firmware efi should do the trick.
    – Eddie Dunn
    May 13 '17 at 18:51
24

Try disabling paravirtualization:

Settings -> System -> Acceleration -> Paravirtualization Interface: None

I was able to start installation of Windows 10 (64bit) on VirtualBox 5.0 Ubuntu by disabling this feature.

4
  • 3
    This worked, I wonder why.
    – pwned
    Mar 8 '18 at 16:22
  • 1
    This worked for me! Thank you... using OSX 10.11.6 and VirtualBox 5.0.14 Jun 2 '18 at 14:58
  • Broke mine, but selecting KVM works Jun 11 '18 at 8:26
  • Didn't work, but disabling the USB Controller did.
    – Val Blant
    Jan 5 '20 at 22:27
5

I removed VirtualBox 5.0 and installed the Oracle VirtualBox 5.1 and it went through. No other options helped.

0
4

I ran into the same problem, and changing paravirtualisation did not help. I had also installed the virtualbox-ext-pack package (Ubuntu host) and enabled USB3.

Unchecking the following allowed me to install: Settings > USB > Enable USB Controller

2
  • 2
    Amazingly this worked! (After trying so many virtualization options configurations...) Thanks!
    – macieksk
    Oct 16 '19 at 15:31
  • This worked for me as well. Win10 1909, VirtualBox 5.1.18
    – Val Blant
    Jan 5 '20 at 22:08
0

The original post is about Linux Mint, but seeing how the other 3 threads link here and this being the first hit on Google when searching for this specific problem I'll leave my comment here

I was trying to create a Win10 VM on a Win10 machine, but I was getting stuck on the install. Tried all of the above, but to no avail. The problem turned out to be that Intel Virtualization wasn't enabled in BIOS. After that I could enable VT-x/AMD-V ( Settings > System > Acceleration ). Not sure if you need Hyper-V disabled, mine was already turned off.

0

If anyone comes across this question as I just did... I tried this on three different mint installs, thinking if I could get it to work on one, I could just transport the finished VM. NONE of the three worked. So I worked my way thorugh proposed solutions until removal of USB worked. So I got curious and just tried a different USB controller, set it to 2.0 and it worked as well, tried it on the other systems and same results on all three. USB3 was default, I guess this happens when you install the extension pack? So consistently I did not have to remove USB, I just set it to USB 2.0.

Installing w10/1909 on mint 18.3 and 19.3, virtualbox 5.1.38_Ubuntu r122592


0

In my case it was stuck during install. I just needed to enable EFI in

Settings > System > Enable EFI (special OSes only)

Not sure if it's the right way to proceed (especially due to the note about "special OSes"), but seems to work so far (you just need to press a key to boot on the installation media at boot time the first time).

-2

I fixed the issue by increasing the number of CPUs from 1 to 4. This might seem obvious but I forgot to check this setting and somehow this was the default for a new VM in VirtualBox.

Not the answer you're looking for? Browse other questions tagged or ask your own question.