1

This question already has an answer here:

I have a Windows 7 desktop computer, I am the only user, with administrative rights. Today I installed a new HDD from another my Windows 7 computer. Now on this HDD I can not access my files and folders in the "Desktop" folder.

When I double click such folder I get a message: "You don't currently have permission to access this folder. Click Continue to permanently get access to this folder". After I click "Continue" I get a message: "You have been denied permission to access this folder. To gain access to this folder you will need to use the security tab." Then I open the "Security" tab, click "Advanced" button, open "Owner" tab, the tab shows: "Current owner: Unable to display current owner.". After I click "Edit" button, I get a message: "You only have permission to view the current owner". After I click "OK" button, a new window shows "Current owner: S-1-5-21-3867894240-3762958599-2688463192-1000" and no option to change that.

The same happens when I try to open or take ownership of my files in the "Desktop" folder.

At the same time I can open files and folders in other directories on that HDD.

How can I take ownership of my files and folders?


UPDATE:

I have Windows 7 Home Premium, so I do not have access to the Local Security Policy Editor. My old computer got broken, so I took the HDD from it and put it into my other computer. The files on that HDD I am trying to access. That is not the HDD from which I boot now. I still hope that I will be able to repair the old computer, and then I will put the HDD back there. So, it is important to keep that HDD workable and preferably bootable. But for now on I need to have access to those files in the "Desktop" folder. For those folders that I can not open, Security tab shows that I already have the "Take ownership" permission but the option is greyed, so I can not change it.


UPDATE 2:

Though copying of the folders did allow me to access them, something got messed up in the system, so that now Avast Antivirus does not allow me to boot Windows. I am still trying to figure it out. Right now I can boot either in the Safe Mode, or with Avast completely disabled in the Normal mode.

Another strange thing: something disallows me to edit security permissions for folders in the boot HDD 'C:\', that is all the allow options are checked for Administrators, but they are also greyed and unchangeable. The lowest editable level is the drive 'C:\' itself. Everything below is non-editable.

Probably set by the antivirus software. Still figuring this out.


UPDATE 3:

I came to conclusion that inability to edit security permissions for inner folders is not a problem. It looks that the security permissions are set to be inherited from the outer folders and they can be edited there. It does not create the problem.

I booted Windows into the Safe Mode and in this mode I can access all files and folders in the Desktop folder on that HDD which I could not access in the normal mode. The owner of all these is set as "S-1-5-21-3867894240-3762958599-2688463192-1000". Yet it does not prevent me from opening them in the Safe boot.

Moreover, the owner of some of my files on that HDD that I could access in the normal boot from the beginning is also "S-1-5-21-3867894240-3762958599-2688463192-1000". Other my files on that HDD that I could access in the normal boot have owner "S-1-5-21-3867894240-3762958599-2688463192-501".

Another interesting thing, I copied a file from that HDD to my disk C:. On that HDD the file has an owner "S-1-5-21-3867894240-3762958599-2688463192-1000". But after copying on the disk C:\, the file's owner now became "User (Computer\User)".

When I copy files and folders from the "Desktop" folder on that HDD to my disk C:\, the file's owner is automatically changed to "Administrators (Computer\Administrators)"

Also, in the Safe Mode I can change ownership of the files and folders in the "Desktop" folder on that HDD. But after I reboot in the normal mode I still can not open the folders, despite I am set as the owner of the folder.

So, me not being set as the file's owner does not prevent me from opening such a file in the normal boot. And reversely, the reason that I can not open those files is not that I am not set as the owner of the files.

marked as duplicate by Pimp Juice IT, G-Man, fixer1234, Twisty Impersonator, music2myear Nov 15 '17 at 22:34

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Your question changed dramatically since Update 2. You should create a new question if you need help with it, and set the answer you had previously as answer. – LPChip May 16 '17 at 14:13
  • I suspect that the copying might have messed up the system. Apparently all these problems are related to security permissions. So just mere copying might not be a good solution if it renders system unbootable. Something else has to be changed. I am still trying to solve it. – and his dog May 16 '17 at 14:19
2

Go to the highest level where you can make changes. If this is the drive letter itself, then use that, for example C:\, but you are likely to be able to do it on the Username folder already (eg: C:\Users\MyUserName)

Keep in mind, if you change permissions on a username folder, the profile itself cannot be booted into anymore. Windows will instead create a temporary profile. So don't change permissions on a working profile folder but login with it instead.

Go to the properties > Security

Press Advanced

Press Change permissions on the bottom, then change the owner.

At the bottom there should now be a button called:
[ ] Replace all child object permission entries with inheritable permission entries from this object

Check this box and press Apply. It will now make the changes to the entire drive from the folder you changed all the way down including the file/folder that gave you problems.

If you can't even change the security settings at the highest level, you will have to backup all data on the drive, then remove the partition and recreate it.

If you don't want to modify the permissions, consider copying the files to a different location from the level where you have ownership, so you can modify the permissions on the new folder if necessary without breaking the old one (in your case copy c:\users\username to c:\users\username (copy) or c:\temp\username).

  • Thats why I added: don't do this on a working profile. But if I understand the question correctly, this is a spare HDD added to an existing setup to copy off files from it. – LPChip May 16 '17 at 10:34
  • You should be able to just login to the profile and be able to access the files on the desktop etc. No need to change owner. If the profile is already corrupt, you won't be able to boot from it anyway, and as such this can be done. – LPChip May 16 '17 at 10:37
  • Yes, thats exactly what I read in his post. – LPChip May 16 '17 at 10:40
  • As I read it, he boots from his old HDD from before the change, and wants to access the files on the Desktop on the newly installed HDD, which is from his old windows install. – LPChip May 16 '17 at 10:49
  • 1
    This is amazing! I just copied the folder and was able to open it and access its contents without changing any permissions. That was so simple. Thanks again for the help! – and his dog May 16 '17 at 12:01
1

There are three things you can try, depending on the situation:

  1. Give yourself the permission to take ownership, in the security tab. This might not always be possible.
  2. Grant yourself the right to take ownership of files and folders. To do this, open Local Security Policy (search it) with administrative rights. Under Local Policies, User Right Assignment, find Take ownership of files or other objects. Edit it and make sure your username listed there. (Be careful to avoid typos!) Restart your computer. Try overtaking again.
  3. Download and burn a Linux distribution that can run as a live CD (like Linux Mint or Ubuntu), use it to access your files, and copy them elsewhere, where access permissions are granted to everyone. You will most likely encounter no problem doing so (owing to the fact that Linux does not honor ACLs) and will have access in that location later. You can now bring them back to your desktop, reassign permissions, etc.
  • Thanks for the help, Fleet Command. I have updated my question. I will try the Linux CD, though I hoped there could be a better way. – and his dog May 16 '17 at 11:45
0

You can try going to Disk Management administrative tool (or Computer Management - Storage - Disk management) and try importing your second HDD as a foreign drive. This should allow you access to the files on that disk without need to reset security.

  • Thanks for the help, Vesper. I could not find the option to import the HDD as a foreign drive. How do I do that? – and his dog May 16 '17 at 11:46

Not the answer you're looking for? Browse other questions tagged or ask your own question.