13

The scrolling speed is too slow. It is a Microsoft Precision Trackpad on Windows 10, but I cannot find any option for scrolling speed in the Settings -> Devices -> Touchpad.

Changing the wheel speed of mouse did not affect the scrolling speed of the trackpad, but only the mouse wheel.

Is there anything like a Registry hack to adjust the scrolling speed of the Precision Touchpad?

2
  • Please edit your question to include the model of your laptop.
    – Steven
    May 16 '17 at 14:39
  • I think the specific model of the laptop would not matter, as this trackpad (Precision Trackpad) is controlled by Windows 10 itself, not by a manufacturer driver. May 16 '17 at 14:46
14

The magic key is:

Computer\HKEY_CURRENT_USER\Software\Microsoft\Wisp\Touch\Friction

Lower is better. Much lower. Simply reboot your machine for changes to instantly take effect.

6
  • 1
    You're not joking when you say magic. I thought it would increase the speed, which it doesn't exactly, it makes it so you can go way further quickly... It works beautifully for me (I set it to 1)
    – trex005
    Dec 12 '19 at 10:40
  • Spot on. Worked beautifully on Dell XPS 7590's trackpad, and overall starts to resemble the feel of the MacBook Pro. Mar 30 '20 at 9:55
  • Doesn't seem to work on ASUS laptops (FX505DV) but +1 anyway for other manufactures.
    – Rob
    Apr 26 '20 at 5:20
  • Fantastic! Works on my Thinkpad Gen6. So strange that it's not a tuneable in the UI. Jan 11 '21 at 8:12
  • 1
    This worked great for me on a Dell Precision 7730, two finger scroll was painfully slow. I kicked friction all the way to 0, not a huge fan of inertia but 10 is not bad, might lower it a bit. Keep in mind, DWORD values are HEX (0 - F = 0 - 15) Nov 2 '21 at 19:14
3

Under this key: Computer\HKEY_CURRENT_USER\Software\Microsoft\Wisp\Touch

Setting "Friction" and "Interia" to a decimal value of 10 for both works for me. This is for my Lenovo Ideapad 330s 14ast.

Make sure you restart your laptop to apply these changes :)

1

There is no hack. At the moment the socalled precision touchpads just have no good driver, and two finger scrolling is essentially broken.

0
1

Seemingly unrelated setting, but it does work:

Control Panel > Mouse > Wheel (tab) > Vertical Scrolling

Then increase the scrolled line number, hit Apply and check the scrolling speed.

4
  • Not working for me. Mar 16 '19 at 0:24
  • not working for me either Jan 10 '21 at 10:45
  • This setting only applies when scrolling in programs and controls using line-by-line scrolling or similar - this is what "notched" scroll-wheels on mice do. What the OP is asking about are the newer "precision" touchpads and "notchless" mice-wheels that offer per-pixel scrolling. The behaviour of precision touchpads is different to notched touchpads.
    – Dai
    Mar 11 '21 at 1:00
  • This is 100% wrong, and you haven't tried this solution at all. You'll find it doesn't work. If you've ever used a modern precision trackpad you'll know what OP is talking about
    – Tom
    Jun 8 '21 at 1:35
1

If your laptop has a Synaptics touchpad, e.g. Lenovo, you can download, unzip and install (by clicking dpinst.exe) this driver: https://download.lenovo.com/pccbbs/mobiles/n1mgx14w.zip + Don't forget to reboot.

This worked for me on Lenovo Yoga 920. I see no new service installed, and the "HID-compliant mouse" (which is the mislabeled trackpad) in the Device Manager still reports the old Microsoft driver.

But the scrolling has improved. (Not a Macbook-level but bearable enough.)

0

So I still haven't found a clean solution to boost the sensitivity scaling on two finger scrolling and the best results always come down to this exact thread. I don't flick so changing friction does little for me. Have you had any successes in workarounds?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.