10

I am having a hard time getting the XML Tools Plugin for Notepad++ running.

I have the newest Notepad++ (v7.4) and the newest XML Tools Plugin (v2.4.9.2 from Sourceforge) both as 64 bit version on Windows 7 (64bit).

First I closed all instances of Notepad++. Then, I copied the XMLTools.dll to the plugins folder of my Notepad++ installation and the dependencies (libs) alongside the notepad++.exe as described in the install.txt.

When I start Notepad++ I get the following error message:

%1 is not a valid Win32 application. XMLTools.dll is not compatible with the current version Notepad++

Error Message after "installing" the XML Tools Plugin to Notepad++ v7.4:

Image]

An hour of googling and trying different versions of XML Tools and even Notepad++ v7.3.1 didn't get me any further. Can anyone help me with this?

Here is my Notepad++ debug info:

Notepad++ v7.4   (64-bit)
Build time : May 14 2017 - 21:02:35
Path : D:\Program Files\Notepad++\notepad++.exe
Admin mode : OFF
Local Conf mode : OFF
OS : Windows 7 (64-bit)
Plugins : mimeTools.dll NppConverter.dll 
  • Using Xml Tools 2.4.9.1 x64 Unicode.zip with Notepad++ 7.5.4 64 bits worked on Windows 10 by following instructions manually. It did not work by using the 64 bit plugin manager. – Javier Elices Jan 16 '18 at 17:15
2

I got the 2.4.9.2 version of the XML tools to work with Notepad++ version 7.4.1 on Windows 10 64-bit by doing the following.

Make sure you have the 64-bit version of the tools. (My first mistake)

Copy the XMLTools.dll file to the plugins directory.

In the download there should be a dependencies folder. Copy all the files in there (I believe there were 6) into the Notepad++ working folder (where the exe file is)

Restart Notepad++

  • 1
    Yeah, that's exactly what I did about 4 days ago (but on that Windows 7 Enterprise machine of course). Didn't work either, still same error. -.- – Lilo May 28 '17 at 0:14
2

Did you follow the installation instructions in 'install.txt'?

Important is you also copy external dll's:

  1. copy new external dll either into npp main folder (same folder than "notepad++.exe") or in %appdata%\Notepad++ folder:
    • libcurl.dll
    • libiconv-2.dll
    • libwinpthread1-dll
    • libxml2-2.dll
    • libxslt-1.dll
    • zlib1.dll
  • 1
    If you would have read my whole description you would have known that I indeed followed these instructions exactly. – Lilo Jun 17 '17 at 12:09
2

First. You must have correct plugins. To Notepad++ 64-bit you must download XML Tools for 64-bit. Simple.

Second. The main folder for plugins in Windows 10 64-bit is in "C:\Users{win_user}\AppData\Local\Notepad++"

Third. In Notepad++ 7.6 or later versions, plugins must have additional subfolder. For Exapmple: "{main_notepad_folder}/plugins/XMLTools/XMLTools.dll" and dependencies are in main folder.

1

I have just had the same problem. It seems to be a bug for this application. I have solved doing the next steps:

  • Install Notepad++ version 7.3.3.
  • Install the xmlTools plugin (v2.4.9 currently).

Now, the plugin works succesfully. The most important thing, you can now upload the Notepad++ version to the latest (currently, version 7.5.6). The plugin still working succesfully.

1

The XML Tools need the Microsoft Visual C++ Redistributable Runtimes 2015. Please install https://www.microsoft.com/en-US/download/details.aspx?id=53840

see SF.net Bugreport

Update

the problem seems to be more caused by libcurl.dll this references to VCRUNTIME140.DLL which comes with vc++ 2015

Internal version numbering

  • I am developing software with that library myself. That was most definitely not the problem. Anyway, the problem has been solved months ago. – Lilo Oct 18 '18 at 21:39
  • I had a clean install of Windows 10. Saw this issue, today. Installed Visual Studio after Notepad++ and spent VS install time troubleshooting Notepad++'s Xml Tools plugin. When Visual Studio finished,I tried to install this and it said VCRedist was already installed. I opened Notepad++. It worked. – Rhyous Nov 7 '18 at 14:06
0

With 7.3.3 the plugin works

enter image description here

, so newer versions broke the plugin because of API change.

Report it to the developers of the plugin so that they can react to the change. We can't fix this for you. so stay at 7.3.3 until a new version of the plugin is available.

  • I've seen the new plugin work with v7.4 but on Windows 10. So that shouldn't be the problem... – Lilo May 17 '17 at 16:28
  • so notepad++ 7.4 uses new functions that are not available in win7 – magicandre1981 May 18 '17 at 17:16
  • Well, using 7.3.3 didn't get me any further, either. :( – Lilo May 22 '17 at 5:48
0

It seems the Windows installation was somehow broken or there was a registry problem or whatever, we will never know.

Anyway, I have a new Laptop now with a fresh Windows installation an everything is working fine now.

No broken API or anything like that either.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.