3

Is there a way to make it so that simply highlighting text in PuTTY DOESN'T automatically copy that text to the clipboard? I want to have to actually right click and select copy or type [CRTL]+[SHIFT]+C to copy.

I've turned off right-click pasting by going to Configuration>Window>Selection and choosing "Windows", but highlighting still copies.

0

4 Answers 4

2

The "copy on selection" feature likely cannot be disabled. The PuTTY manual (specifically 3.1.1 Copying and pasting text) does not specify any way to disable copy on selection.

As a workaround, consider using a different client. I use Cygwin which includes mintty terminal client which does have an option to disable "Copy on select."

2
  • I've been using Cygwin for 10 years and I love it. Sadly, my new company appears to use an antivirus that conflicts with the installer. For now, I'm stuck with PuTTY.
    – ewok
    May 17, 2017 at 1:21
  • The line for the configuration file (~/.minttyrc) is CopyOnSelect=no.
    – Kevin
    Aug 22, 2019 at 12:55
1

You can Disable copy/ paste by going to putty configuration \ windows \ selection

then change "Mouse Paste Action" to "No Action" to disable mouse paste and then uncheck "Auto-copy selected text to system clipboard" to disable mouse copy

then save to session settings for all sessions

0

Just go to Selection settings and change two settings:

  • Action of mouse buttons -> from Compromise to Windows (Right click brings menu)
  • Assign copy/paste selected actions to clipboards (remove checkbox mark)
1
  • 1
    Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Jun 8, 2023 at 9:11
0
To disable copy on text selection:

In PuTTY Configuration | Window | Selection, uncheck Auto-copy selected text to system clipboard.

To disable paste on right click:

In PuTTY Configuration | Window | Selection, for Action of mouse buttons, choose Windows (Middle extends, Right brings up menu).

To save these as default settings:

In PuTTY Configuration | Session, choose Default Settings, then click Save.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .