I have a .csv file which has Unicode characters when I want to import it to Excel, it shows some garbage instead of the Unicode characters.

I googled and found some tips but did not work for me.

I try to import the file as follows:

  1. First, it does not show UTF-8 option in file origin:
    no utf-8 here

  2. I can see the right preview of the data here:
    right preview

  3. When the file is imported I cannot see the right data. Excel shows garbage data instead.

  • Which version of Excel? Could it be that not all needed modules are installed? If I check this with Excel 2016, I see ~100 possible encodings in that dropdown, including Unicode (UTF-8).
    – Berend
    May 17, 2017 at 9:23
  • I have installed Ms. Office 2013 with typical installation. May 17, 2017 at 9:57
  • No idea what's included in a 'typical' install, you may want to re-reun the installer and check if there's an optional module for this. But maybe utf-8 support was added after 2013.
    – Berend
    May 18, 2017 at 6:36

2 Answers 2


This is a known bug in Excel.

A known reported workaround is to close Excel, then open a command prompt as Administrator (Windows search -> 'cmd' -> Right mouse click on Command Prompt -> 'Run as Administrator') and run the command:

sfc /scannow

Then open Excel again, and check if all encodings are listed now.


Although it's a bit late, I will share my findings for future headaches.

I had a similar problem and the solution was on the system locale...

enter image description here

I disabled this beta feature and everything was fine.

Good Luck!!!


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .