0

I'm triple booting Windown 7, Windows 10, and Ubuntu. rEFInd had been working fine for me for a long time. Until it suddenly started boot looping ... that's not an entirely accurate term though. Here's what happens when I switch my bootloader to rEFInd:

  • The screen flickers blue and the PC reboots.
  • This happens anywhere between 3 to 10 times (I don't know what finally clicks to break the loop).
  • When it finally does boot, there's no sign of rEFInd. It just boots my default OS.
  • If I dare press a key during any of this, the boot loop continues on and on. I've given it up to half an hour and it won't continue.

I don't know when exactly this started and I can't seem to find a log, but I have a few suspicions. The issue started roughly around the time when I...

  • Bought my 4K monitor. I have a 4K and an FHD monitor (previously had 3xFHD and it ran fine).
  • Tried to set up a hackintosh, but because I have a Mac Mini it really wasn't a priority so when it didn't work I didn't bother with it.
  • either Ubuntu or W10 changed my bootloader from rEFInd to itself (so the issue may have happened long before when I noticed it)

How do I go about debugging this?

1

rEFInd produces no log files, I'm afraid. That said, it's unclear if rEFInd is even launching. It sounds a bit as if the EFI is trying to launch one boot loader after another, and after each failure it's moving on to another boot loader in the boot options list, or possibly rebooting, until it succeeds.

Some questions and debugging/repair tips:

  • You say that the system reboots. Are you positive of this, or might it simply be moving on to the next boot loader after a failure of the preceding one? A reboot will usually be accompanied by the re-appearance of the manufacturer's logo and POST screen.
  • You say your computer eventually boots the default OS. Is this the default as set in the EFI's NVRAM (and shown by sudo efibootmgr, EasyUEFI, and similar tools) or the default as set in rEFInd's refind.conf configuration file? If you adjust the refind.conf default, does that change the OS that boots?
  • The output of sudo efibootmgr -v in Ubuntu, or the boot options shown in EasyUEFI, may be helpful in diagnosing your problem.
  • Depending on what efibootmgr or EasyUEFI shows, you may be able to fix the problem by adjusting the boot order using the same tool.
  • If the problem is caused by extraneous programs, like whatever Hackintosh boot loader you installed, removing it may help. Check your EFI System Partition for such programs. Clover, for instance, would normally be in EFI/Clover on the ESP, IIRC.
  • If rEFInd is malfunctioning, removing it from the ESP may be helpful; however, if you rely on rEFInd to boot Ubuntu, doing so will render Ubuntu unbootable until you resolve the problem and re-install either rEFInd or another EFI boot loader for Linux, such as Ubuntu's default of GRUB 2.
  • It's conceivable that the problem is related to a damaged ESP filesystem. If so, repairing it (with dosfsck in Ubuntu or CHKDSK in Windows) might help. Note that damaged ESPs can be caused by a failure to disable Fast Startup and Hibernate in Windows. See here and here for information on how to disable these features.
  • If rEFInd doesn't like your 4K monitor, it's conceivable that adjusting the resolution line in refind.conf or uncommenting the textonly line would help; however, there's a chance that this would make matters worse, too, so proceed with caution.
  • If possible, try unplugging your new 4K monitor and plugging in a lower-resolution monitor to see if that helps.
  • If you can boot into your Ubuntu installation or an Ubuntu emergency disk, you could run the Boot Repair utility and select the "Create BootInfo Summary" option. (DO NOT click "Recommended Repair," at least not yet!) When asked whether to upload the report, click "Yes," and then post the URL provided here. This should provide helpful diagnostic information on your configuration, although your problem is unusual enough that clues may be scarce in the output. Still, it's worth posting that information.

I can't promise that any of these tips will resolve the problem or even produce information that will help you resolve the problem, but they're what springs immediately to mind.

  • Thanks, Rod. With so little EFI knowledge, forming the proper question was a bit difficult. I think you're right in that rEFInd is not even launching. I disconnected all the SSDs and it was fine. Then I plugged in the hackintosh boot USB and the flickering is back. It seems that the UEFI bios was having a problem with that specific configuration of 'Clover' OR the way my SSDs were connected. I ended taking the GPU out (blocks my SSD ports), removing all SSDs and reconnecting them. It works now and I think the problem was actually my DVD drive. In older versions of my BIOS it also misbehaved. – copolii May 19 '17 at 17:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.