2

MS17-010 doesn't appear to support Windows 8 Embedded. The patch that came out with Windows Updates in March supports Windows 8.1. There are links to manually downloading the patch KB4012598 for Windows 8 (Doesn't mention embedded) but they don't install. Was 8 embedded left out?

3

Is there a WannaCry patch for Windows 8 Embedded?

It was released back on March 13: KB4012217

  • March, 2017 Security Monthly Quality Rollup for Windows Embedded 8 Standard for x64-based Systems (KB4012217)
  • March, 2017 Security Only Quality Update for Windows Embedded 8 Standard for x64-based Systems (KB4012214)
  • March, 2017 Security Only Quality Update for Windows Embedded 8 Standard (KB4012214)
  • March, 2017 Security Monthly Quality Rollup for Windows Embedded 8 Standard (KB4012217)

Patches That Fix the Vulnerability For MS17-010

| improve this answer | |
  • I don't see the point of linking to the patch on: Microsoft Catalog Update website but would if that's requested. – Ramhound May 17 '17 at 16:17
  • Hi, thank you for the information. I have Windows Update set to Auto, but nothing was installed during the month of March other than a Visual C++ update. I do not see KB4012217 installed. Strange. I will see if I can find this patch on MS Web site as a download and see if I can get it installed. Not sure why it wasn't included in the auto updates. Anyway, thank you again for this article link as it's been very hard to find anything about this patch for Embedded 8. Cheers! – user729247 May 17 '17 at 16:44
  • I was able to find and download this update from Microsoft. Thanks again!!! – user729247 May 17 '17 at 16:54
  • Well, this patch doesn't install on my WE8 system either. I wonder if there is a newer Security Monthly Quality Rollup that included these updates that was installed prior to March? Anyway, still trying to determine if this patch has been applied to my WE8 system or not. Cheers. – user729247 May 17 '17 at 17:01
  • 1
    @user729247 - I wonder if there is a newer Security Monthly Quality Rollup that included these updates that was installed prior to March? - Nope. Anyway, still trying to determine if this patch has been applied to my WE8 system or not. Cheers. - There are only two possible patches KB4012217 or KB4012214 that patch this vulnerability. You really should determine the reason KB4012214 is not being installed though. – Ramhound May 17 '17 at 17:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.