0

I have two wifi access points on the two stories of the house. Let's call them 1 (modem/router on the first floor) and 2 (router in bridge mode fed by 1 through ethernet cable on the second floor). They both broadcast the same SSID, but on different wifi channels (sufficiently distant from each other).

Since I have replaced 1 with a stronger router I have difficulty connecting to 2 even in the most remote part of the 2nd floor, and even when the signal from 1 is much weaker than that of 2 (to the point that network resources become hardly accessible or even inaccessible).

I wonder what parameters the wifi drivers of my devices take into account when they choose the access point to connect to (I have only macOS and iOS devices). And is there any way to tell a device to connect to the router that is actually closer?

Unfortunately 1 is the ISP modem and I can't tweak its radio power, and 2 already transmits at 100% power. So, that is not a parameter I can play with.

See below two screen shots of the signal quality measurements from macOS on the 2nd floor. Weirdly enough my devices constantly prefer 1 over 2, regardless of the signal quality and no matter where I am in the house.

enter image description here enter image description here

0

The network name (SSID), security type, and passphrase must all be exactly the same. So you need to switch router 1 to WPA2-only mode to match router 2. And make sure their network names and passphrases are exact matches while you're at it. Capitalization, punctuation, spaces, accent-marks (diacritics) all matter.

Also please beware that your two routers aren't exactly on different channels. With 802.11ac's "VHT80" 80MHz-wide channels, it uses the old 20MHz-wide channels of 36+40+44+48 as one 80MHz wide channel. So you need to put your second router on 149-161 or a DFS (radar) channel (52 - 144) so their 80MHz-wide channels don't overlap.

  • I noticed both these issues after posting the question. I have changed both and the same happens. Very weird. – retrography May 17 '17 at 20:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.