0

I recently installed Remote Desktop Manager on Windows 10 v1703 which unfortunately stole the file associations for .RDP file types. I want to reset this back to the default MSTSC which it has historically been.

When I access the "Default apps" screen the reset button only resets the Browser/Email and other items on the home page. Going into "Choose default apps by file type" I can see the entry for RDP but the only options for association are "Remote Desktop Manager" and "Look for an app in the store". Going into "Set defaults by app" shows that Windows 10 does not have an entry for MSTSC.

Uninstalling Remote Desktop Manager removes the association, but does not restore it to the previous value. The only option present is now to choose an app from the store.

Is there an easy way to reset the association or choose a random application from outside the pick list?

  • 1
    Have you tried find the registry entry for the .rdp file association? You should be able to just select the executable for MSTSC when your prompted to select a program from the list like always – Ramhound May 17 '17 at 17:12
  • Just to double-check, have you already tried to perform a System Restore and drop back to a point in time prior to when you installed the Remote Desktop Manager? – Run5k May 17 '17 at 17:40
  • @Ramhound the UI will only let me choose from a list, or to install an app from the store. I have not tried directly modifying the registry as previously these changes were easy from the W7-style UI. The option to choose an arbitrary executable from the local system seems to be gone now. – Melikoth May 17 '17 at 18:32
  • @Run5k System restore did not restore the old associations. I tried the restore point from prior to the install, and a system restore point from ~1.5 days ago. The software reverted to the previous version, but the modified associations persisted through the restore. – Melikoth May 17 '17 at 18:33
  • 1
    Well thats the wrong menu. Open With --> – Ramhound May 17 '17 at 18:38
1

Run two commands in CMD to find associations of .RDP file::

assoc .RDP
ftype RDP.File

Here are the results RDP.File="%systemroot%\system32\mstsc.exe" "%1". You can associate the files with assoc and ftype commands.

Default RDP file associaton

To associate type these commads::

ASSOC .rdp=RDP.File
FTYPE RDP.File="%systemroot%\system32\mstsc.exe" "%1"

Find more in Registry settings::

[HKEY_CLASSES_ROOT\.RDP]
[HKEY_CLASSES_ROOT\RDP.File]
  • I'm seeing the same thing on my home machine, I'll have to give this a try next time I'm in the office. – Melikoth May 27 '17 at 14:40
0

I'm not sure why the comment above about Right-clicking the file and selecting "open with" has two negative votes. That is probably the easiest way to go. If you right click a file with an .rdp extension, select "open with", choose another app, and scroll down to the bottom, you have the option to browse your computer for the program you want to open it with.

Make sure the "always use this app to open this file type" box is selected (wording is from memory, but you get the idea), and browse to c:\windows\system32\mstsc.exe as the program to open with. Voila! Re-associated.

-1

Right click on the file itself, click "Open With" then "Choose another app" then "more Apps" then scroll down to the button then "Look for another app in PC"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.