I have multiple gmail accounts that don't use two-factor auth and these work perfectly with Evolution. The setup wizard pre-populates all the required settings. I'm having trouble with a Gmail account that uses two-factor auth. I have Evolution on Ubuntu 16.04.2 LTS 64 bit.

When I tried to setup a gmail account with two-factor, I naturally have no way to enter an auth token. So I setup an App password for that account in Gmail's security settings.

When I entered the email address in Evolution's account setup the wizard wasn't able to auto-fill all the settings, so I copied these from one of the other accounts that was working. I.e. receiving mail from imap.googlemail.com on port 993, SSL on dedicated port, Authentication: password. Sending mail to smtp.googlemail.com on port 465, Authentication: Login.

When I try to retrieve my mail I'm shown a 'Mail authentication request' dialog. I enter my email address and the App password that Gmail provided. Evolution continues to prompt for these details, so presumably they aren't being accepted.

How do I set this up to work correctly?

2 Answers 2


You need to set up an app specific password here https://myaccount.google.com/apppasswords


I received a "Review blocked sign-in attempt" for this email account. Since this was a business account I couldn't 'allow less secure apps access' as suggested by the email. I needed to go to the Google Admin setting for the whole domain and enable 'Allow users to manage their access to less secure apps'. After doing this I went back to the allow less secure apps setting on my account and was then informed that I couldn't switch it on anyway since I had two factor Authentication enabled. Then my email started working...

So I think you need to enable less secure app access for the entire domain, then under two factor auth you can setup an app password, then use that to collect your mail.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.