1

I have a Sony Gold Wireless headset and it works perfectly fine, the only issue is that the windows volume Control (the slide in the task bark) doesn't affect it at all. So in order to change the volume i have to either use the built-in buttons of the headset, or whatever software am currently using, this is not a critical issue but am very used to the volume buttons i have in the keyboard (specially the "Mute" button).

What i tried so far :

  • Making it the default playback device : enter image description here

  • Enabling bluetooth services : enter image description here

I also tried using the "troubleshoot tool" and updating the driver, nothing solved this issue, because like i said, the headset is playing Sound correctly, its just that somehow it overwrite windows sound control or something.

Also did some comparison with my Razer headset and i noticed something a bit weird,

In my other Windows-10 pc, when playing AC/DC - Highway to hell solo on full volume, the playback device volume bars looks like this :

enter image description here

Playing the exact same song from the exact same source (Spotify) with full volume and also with the Razer headset, the volume bars don't get passed "4-5 bars" even thought that in my ears it's as loud as the other computer :

enter image description here

And for the sony Headset, it shows the same result in the "bad" and "good" PC (can't pass 4-5 bars) :

enter image description here

I have no idea if this can help or even if it has any meaning but I just noticed that its kinda weird, even when i use the speakers the volume bars are always limited to "4-5 bars".

But again, my main issue is that i want this slider

enter image description here

to work, Cause even that its set to Mute, Windows is still doing a tons of Sound.

Thank you

Edit

Totally forgot to say that am running :

Windows 10 - Pro; Version 1607

Edit 2

Another thing that i forgot, using the volume mixer has some strange results too, changing the volume of an individual software works perfectly :

in this screenshot

enter image description here

I was able to reduce Spotify volume to ~30%.

Then i took it back to match main system volume (100%) and then reduced the whole System volume

enter image description here

,and as always, absolutely no effect, even when its muted.

5
  • Why are you comparing a PS headset to a PC headset?
    – Ramhound
    May 18, 2017 at 3:20
  • @Ramhound the Razer is also a ps4 headset, i actually bought it for the ps4 until i wanted to play wirelessly, also am comparing just to showcase some "weird result" but that is not the main issue, the issue is that windows is fully recognizing a device, but simply wont control its system volume, cause the windows volume has nothing to do with the actual hardware settings in the device, you can have a speak at full volume but still able to mute it from the system, i can't do that with the bluetooth headset May 18, 2017 at 3:24
  • Honestly it just sounds like a limitation of your PC. The Kraken is working because it's a generic USB sound device. It sounds like your Sony headset is simply not being detected 100% correctly
    – Ramhound
    May 18, 2017 at 3:29
  • Try enabling virtual surround sound (properties of your sound device) within Sound
    – Ramhound
    May 18, 2017 at 3:40
  • enabling virtual surround don't do anything May 18, 2017 at 4:37

1 Answer 1

1

Got the same problem, but I managed with a workarround to make the media keys to affect the sound.

I installed the NirCmd, a nice utillity for windows where you can run a specific command as change the volume for a specific application (or the current one). What I did:

  • Installed NirCmd and added to the Windows Directory (to run from anywhere)
  • Created two scripts: "Volume+.bat" and "Volume-.bat" with the following contents:

Volume+

nircmd changeappvolume Spotify.exe +0.1
nircmd changeappvolume focused +0.1

Volume-

nircmd changeappvolume Spotify.exe -0.1
nircmd changeappvolume focused -0.1

Then, using the AutoHotKey app, I created this config:

Volume_Up:: Run, pathtobat\volume+.bat, , Hide
Volume_Down:: Run, pathtobat\volume-.bat, ,Hide
RETURN

Now, using the media keys feels very natural, affecting the backgroud music and the active window.

6
  • thanks man! never heard of nircmd its gonna be very useful Nov 25, 2017 at 14:01
  • hey man, the "nircmd changeappvolume Spotify.exe +0.1" doesn't do anything (running the command directly without auto hot key) any idea what's going on ? Dec 8, 2017 at 12:31
  • Any error? Try other nircmd commands. The command should work, even without AutoHotKey.
    – Vagner Gon
    Dec 8, 2017 at 17:37
  • no error, i just tested other commands and they work, this appvolume thing doesn't work, does it still function for you ? thanks Dec 8, 2017 at 21:27
  • 1
    Yeah, just tested on Spotify and worked fine.imgur.com/a/iOAWF
    – Vagner Gon
    Dec 10, 2017 at 20:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.