2

How can I do a fresh OSX install with only access to linux?

I have a mac and the hard drive had an obvious physical crash after an encounter with a strong magnet. I put a new drive in but it seems all instructions for fresh-installs on OSX make use of another mac. I have linux machines (all debian flavors if it matters) but no other macs.

This related question is more narrow and doesn't seem to have a definitive answer anyway.

  • What model? Many of them let you do a network install from bare metal – Journeyman Geek May 19 '17 at 12:05
  • @JourneymanGeek The model says A1286 but that seems to be a large range. I tried a serial number lookup and got this: MacBook Pro (15-inch, Mid 2012). That sounds about right. I'll see if I can find some kind of netboot option. – kobejohn May 19 '17 at 12:11
  • 1
    Looks like you'll need access to some version of OS X - apple.stackexchange.com/questions/128319/… – ivanivan May 19 '17 at 12:18
  • From how to reinstall It says Option-Command-R for latest version reboot. I'll update if it works even on 2012 model. – kobejohn May 19 '17 at 12:19
  • It should, it should apparently work on anything newer than 2011 – Journeyman Geek May 19 '17 at 12:20
2

Your mac seems just new enough to be able to reinstall over the internet (2010 and 2011 models would need a firmware upgrade). I've done this a few times in a past job and its pretty self explanatory, but you'd want to read apple's docs anyway

Install your new hard drive, then turn on while pressing the appropriate key combination - command-option -R would give you internet recovery in any case.

Hold it down until you see an apple or spinning globe logo. This should then load the recovery utilities and you can be on their way.

  • Great. I will try it as soon as I have a chance and update here. Many thanks. – kobejohn May 19 '17 at 12:26
  • 1
    Just to note: You will get the OS the machine first shipped with, as that's the only one available without an AppleID sign-in; sign-in is not possible at that point. You can always update afterwards. – Tetsujin May 20 '17 at 9:59
  • Ah. We ran out own server that hosted images iirc so that wasn't an issue. Something called munki iirc – Journeyman Geek May 20 '17 at 11:31
  • 1
    @Tetsujin my experience matched your advice. command-option-R seems to work until the point that it tries to confirm installation. Then it just ignores you when you try to continue. Unhelpful errors are visible if you check the log. Plain command-R to install the original OS followed by an upgrade worked well. Thanks for everyone's help! – kobejohn May 21 '17 at 0:56

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.