Archwiki (https://wiki.archlinux.org/index.php/xprofile) I should use .xprofile for loading software and execute scripts at startup.

I am not using archlinux (I use debian, jessie) ~/.xprofile is ignored, I think.

up vote 2 down vote accepted

How Debian handles the Xsession startup is summarized e.g. here.

I would first try to put what you have in your ~/.xprofile into an ~/.xsessionrc (you might have to create it). This should not interfere with however the rest of your startup is working.

However, from the same page:

Also note that because ~/.xsessionrc is read very early, any settings you place here may be overridden by your window manager or desktop environment, later in the login sequence.

  • I will try that out – user729963 May 19 '17 at 16:38

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.