11

My Goal

I am trying to use a webcam for my Windows 10 x64 Desktop. However, when I try to use a program that uses a webcam, such as Skype, I get the message "Your webcam is currently being used by another application" in the program or some variation of that.

My Attempts

I've already taken a look at Cam being used by another application with no success.

Here is what I find when I click on "Driver Details".

  • C:\WINDOWS\system32\DRIVERS\edevmon.sys
  • C:\WINDOWS\system32\drivers\ksthunk.sys
  • C:\WINDOWS\system32\drivers\usbvideo.sys

When I try searching for the camera using Process Explorer, nothing is found. I also searched for the physical diver name.

I've tried...

  • using two different webcams from two different companies
  • used Skype, Google Hangouts, and other webcam software
  • disabling then enabling the device.
  • uninstalling and reinstalling the device.
  • installing the "USB Video Driver" driver.
  • installing the divers given by the company of the device.
  • using both USB 3.0 and USB 2.0 slots
  • closing out of arbitrary programs in hope of getting it to work
  • using a registry cleaner such as CCleaner
  • restarting the computer
  • disabling ESET Smart Security (in case it was blocking it for some reason)

Help

Willing to try anything that doesn't involve a clean install of windows.

  • 1
  • 1
    Unfortunately, this is a moving target sort of question. My business has conference room laptops which must, must, must always be able to connect Skype to the external USB webcam. Zero problems, zero testing, zero configuration, zero embarrassments for C-level execs with visitors and potential clients. Windows 10 has broken USB webcam compatibility half a dozen times. Some of the fixes you'll find will work for v1507, v1604, and now v1703. The problem will keep coming. – Christopher Hostage May 19 '17 at 23:19
  • @ChristopherHostage besides the one problem I had, with my web camera which was cause by a driver, I have never had a problem with any web camera on Windows 10 – Ramhound May 20 '17 at 2:30
  • 1
17

Right click on windows icon on the left corner of the taskbar. Click on the settings icon (just above the power icon), this will open windows settings panel. Click on the privacy icon (lock symbol), to open the privacy panel. Click on the camera icon, to open the camera privacy settings panel. select on or off for each application. To use camera with Skype: switch it on for Skype. Now the camera works with Skype.

1

ESET Smart Security has a webcam setting that cannot be toggled off by disabling ESET Smart Security.

In order to fix my problem, I had to go into the ESET Smart Security advanced settings and turn off Webcam Protection.

0

Go to device manager -> Cameras -> integrated camera *right click and then click Disable device after some seconds right click and click enable device.

As you said, nothing else worked for me as well. But this method worked well. It might work for you as well.

-3

I have a Dell laptop. I first went to YouTube and did as instructed in this video. I set the lid when closed to hibernate in stead of sleep.

I than went to device manager and uninstalled driver in imaging. I did a restart and the camera worked great. When I shut the lid and reopened it several times the camera always came on.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.