1

My host OS is Windows 10, my virtual machine is Ubuntu Mate 16.
VMWare version is 12.5.
The mount path looks like this: /mnt/hgfs/{mysharedfolder}.
And it is set to 'root' user/group per default. I want to change it to 'www-data'.

The problem is that none of the proposed methods on internet are working to change the ownership of the shared folder. Apparently with the latest version they changed something.

These are what I tried so far:

  • under 'etc/init.d' I edited the 'vmware-tools' file:
    # Mount all hgfs filesystems

    vmware_mount_vmhgfs() {
      if [ "`is_vmhgfs_mounted`" = "no" ]; then
        if [ "`vmware_vmhgfs_use_fuse`" = "yes" ]; then
          mkdir -p $vmhgfs_mnt
          vmware_exec_selinux "$vmdb_answer_BINDIR/vmhgfs-fuse \
             -o subtype=vmhgfs-fuse,allow_other,uid=33,gid=33 $vmhgfs_mnt"
        else
          vmware_exec_selinux "mount -t vmhgfs .host:/ $vmhgfs_mnt -o uid=33,gid=33"
        fi
      fi
    }
  • tried to directly edit '/etc/fstab' and the os didnt boot to GUI anymore, I had to remove the line from command line.

    .host:/{shared-folder} /{path-to-mount-on} vmhgfs defaults,ttl=5,uid=33,gid=33 0 0

  • naive attempts like manually unmounting and remounting the path, using chown or chmod are useless since the system reverts corresponding changes immedietly. Also tried to mount with this:

    vmhgfs-fuse .host:/ /mnt/hgfs -o uid=1000 -o gid=1000 -o umask=0033

Is there any updated solution to this ?

0

Thanks for your post. I recently started having the same issue.

My host OS is MacOS, my virtual machine is Debian GNU/Linux 9 (testing). VMWare version is Fusion 8.5. The mount path looks like this: /mnt/hgfs/{mysharedfolder}.

My previous solution was to edit /etc/fstab to have uid,gid set as you show in your second option. This worked without issue until a month or so ago, after a routine debian-side update. Then the virtual machine would not boot. So I also had to remove that line from /etc/fstab.

Next I upgraded vmware to Fusion 8.5 and Debian from stable to testing. Same issue remained. If I use the latest VMware tools (10.1.6), the shared files are mounted on startup, but with the wrong uid,gid. If I instead use open-vm-tools (debian package, as recommended by vmware), the shared files are not even mounted.

I just tried your first solution (edit /etc/init.d/vmware-tools). That worked for me. Thank you!

If it doesn't work for you, perhaps ubuntu is not running this script at startup.

Does this line (or something similar) work if you try it at the command line?

sudo vmhgfs-fuse .host:/{name} /mnt/hgfs/{name} -o nonempty,rw,uid=1000,gid=1000

The -o nonempty is required to try to mount a share that is already mounted by the system. I don't think you want to use this command as the solution, but just to diagnose whether that would successfully change your uid,gid. If it does, you may need to find out what script ubuntu is actually using on startup. If the command doesn't work, not sure what to suggest. I could not get a mount command to work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.