1

I'm trying to repair my computer from booting into a blackscreen through the CMD mode (safe mode isn't working), after seeing that Startup Repair couldn't repair my PC. When I type sfc /scannow, I get the following message:

There is a system repair pending which requires reboot to complete. Restart Windows and run sfc again.

So I tried running sfc /scannow /offbootdir=C:\ /offwindir=C:\Windows and after around a minute of waiting since the sfc began, this message appears:

Windows Resource Protection could not perform the requested operation.

I cannot simply "reboot" to get rid of that pending repair because I'm stuck in a blackscreen with only my cursor appearing and nothing responding, not even Ctrl+Alt+Delete. I would need to reboot straight into the recovery menu, but I have no idea how to do that. Switching to integrated graphics or going into a safe mode does not get me past the blackscreen. I also tried a chkdsk which found no errors.

Then I tried doing a dism /online /cleanup-image /restorehealth which told me that the component store corruption was repaired. However, I heard it still requires a reboot to fix sfc, and after restarting twice during the Windows boot logo and then getting into recovery options again, I'm getting that restart pending message again when running sfc /scannow. The dism /image:C:\ /cleanup-image /revertpendingactions requires a reboot too, so it's of no use here, unless I can reboot directly into the recovery menu. I found a pending.xml file under X:\Windows\WinSxS (not under C:) which I deleted and successfully ran sfc /scannow afterwards, but after reaching 100% I was left with the Windows Resource Protection message again, same as with the offline parameters.

Another suggestion I found was to try ICACLS C:\Windows\winsxs, which tells me that it successfully processed 1 file and failed processing 0 files, but that does not change anything on sfc.

As a last option I tried reverting to two of my images automatically created yesterday and two days ago, but each gave me this error:

System restore failed to extract the original copy of the directory from the restore point. Source: %ProgramFiles%\WindowsApps Destination: AppxStaging An unspecified error occured during System Restore. (0x80070057)

Here is my CBS.log And my SrtTrail

For information, the blackscreen problem started suddenly after I left my computer running through the night to finish some downloading (not installing anything), but it's possible that a BSOD occured during the time, which I am getting at least once a week these days (for numerous errors that I'm never able to fix)

Edit: Just finished downloading and creating a bootable recovery DVD, tried the above steps through it but it doesn't seem to be any different.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.