4.9.0-2-amd64 #1 SMP Debian 4.9.18-1 (2017-03-30) x86_64 GNU/Linux
kde-plasma-desktop                            5:92

This is my problem, I have a high density display so I need to scale my screen to 1.5 to make it usable.

This is screen scaling feature to which I am referring: enter image description here

But I also use Android AVDs which don't respond well to the screen scaling (see my post about this issue)

So what do I do about apps that break when the screen is scaled? Can I disable scaling for a specific application?

1 Answer 1


Run QT_SCALE_FACTOR=1 to disable scaling for that application.

Example: QT_SCALE_FACTOR=1 emulator -avd n5 -verbose

Alternatively, you may consider reverting the scaling, then starting other applications with QT_SCALE_FACTOR=1.5.

High DPI Displays | QT 5.8

QT_SCALE_FACTOR [numeric] defines a global scale factor for the whole application, including point sized fonts.

  • 2
    So I actually had to scale it by QT_SCALE_FACTOR=.66. Now is that because I already had my desktop scaled to 1.5 and the QT_SCALE_FACTOR is relative to the current scaling size? May 22, 2017 at 20:32
  • Unsure. I didn't play around enough with the setting to determine that.
    – Steven
    May 22, 2017 at 20:33
  • QT_SCALE_FACTOR=.66 didn't work but GDK_SCALE=.66 worked Jun 14, 2020 at 14:18
  • This does not seem to work for KDE with wayland. Bug report bugs.kde.org/show_bug.cgi?id=441705
    – Max
    Nov 19, 2021 at 22:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .