0

I have been using Windows 7 for about 6 years and never seen anything like this before. It looks like something had messed up security on my computer. I suspect it could be either a recent Windows update, or an antivirus, or AdobeARM (already removed). It looks like my administrator's rights had suddenly become limited.

I am a single owner of a desktop computer that runs Windows 7 Home Premium with SP1. It also has COMODO Firewall with HIPS, Avast Free Antivirus and Malwarebytes 3 (the latter two have real-time protection off). Antivirus scans report no threats found. According to the OS I am an administrator on the computer. [img] Now just one of the weird things as an example: I have installed a program Foxit Reader, and it created a shortcut on the desktop. I can not rename this shortcut - when I try, I first get a message: "You'll need to provide administrator permission to rename this file". [img]

After I click "Continue", I get another message: "File Access Denied". [img]

After this, clicking "Try Again" just keeps producing the same message.

I have already found a number of workarounds for this particular manifestation of the problem:

1) I can copy the shortcut to another folder, rename it in that folder and then copy it back on the desktop.

2) I can boot Windows into the Safe mode and in that mode I can rename the shortcut right on the desktop.

3) I have created Administrator account on the computer and when I logon into that account I do not get security restrictions, can rename whatever I want and open any folder, without any "Access denied" messages.

What I am interested in right now is not a workaround (because this is by far not the only "Access denied" restriction that I presently keep getting), but a solution how to reset my administrator's rights so that the system stop giving me "Access denied" messages.

How can I reset full administrator's rights for my account?


UPDATE:

I want to emphasize again: I am not looking for a solution to rename the shortcut. I want to get rid of the "Access denied" restrictions in my account. I do not get such restrictions from the other Administrator account. As to this particular the file permissions: img img


UPDATE 2:

I just renamed my account from "User" to "SuperUser". It turned out, when it comes to file permissions, the system does not regard me as an administrator: [img7] And this is how it looks from the other "Administrator" account: [img6]

So it seems like an unknown program (most likely AdobeARM) had changed my account type from "Administrator" to "User", but the change is made only in one certain place, so that the "Control Panel" still regards me as an Administrator. How can I undo that change?

  • Your screenshot indicates your using the built-I Administrator account there a reason for that or the username of that account simply User? – Ramhound May 23 '17 at 2:16
  • I am not quite sure, since it has been a while, but I believe I gave my account a name "User". – and his dog May 23 '17 at 2:37
0

It sounds as though there may be a security permissions issue on the primary account's desktop folder as the root cause of the issue.

But since you are able to create a second administrator account. What you can attempt is to log into that second account. Remove admin from your primary. Log into the primary, verify that admin has been removed. Log out. Log back into the secondary and grant full admin again to the primary account. Failing this, I would look at the permissions on the C:\Users\User\Desktop folder.

| improve this answer | |
  • Hi, Sorean. I did according to your recommendation. I logged off from the "User" account and logged into the "Administrator" account. From that account I changed the "User" account type to "Standard user". Then I verified the change from the "User" account. Then I changed the "User" account type back to "Administrator". Unfortunately, all of these had no effect on the problem. – and his dog May 23 '17 at 3:03
  • Then as I suggested, it may be a permissions issue on your Desktop folder. Check the security settings on that folder. I noticed that there is a special setting on the account which is inherited from the parent object, which in this case is the desktop folder. Reset the permissions on that folder and all subfolders. – Sorean May 23 '17 at 16:09
  • 1
    It may also be because it is on the C:\Users\Public\Desktop folder as well. I don't know where the shortcut itself is located. – Sorean May 23 '17 at 16:12
0

I was having the same problem. I couldn't access three subfolders in a folder. I selected one of the folders, went ino properties/security and edited permissions to give full control for that folder to authenticated users. After applying, in can access all three subfolders using the administrator account that was previously denied. Then, I changed the permissions for the folder I had modified back to their original state just to see what would happen. My administrator account still has access. Weird little glitch.

| improve this answer | |
  • Update: an hour or two later I tried deleting the folder and was denied again. I am Jack's disappointed sigh. It's stupid, I just want to delete a couple of empty folders. Just grateful they are empty. – DaMonkey Oct 31 '18 at 6:37
  • Update: Download LockHunter (free) from lockhunter.com/download is.htm – DaMonkey Oct 31 '18 at 6:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.