0

I am quite new to SSH and Ubuntu. I am trying to connect to a server (e.g. server1.com) via SOCKS5 proxy host (e.g. proxy1.com) for which username and password is already given. I am including the jump host directives and path to proxy username and password in the SSH config file but no luck until now as I am always getting an error:

unable to resolve proxy hostname

My .ssh/config file format is as below:

Host host1
HostName server1.com
Port 22
ProxyCommand ssh username:password@proxy.com portnum %h %p

And then I am using ssh host1 to initiate the session.

Can anyone give me the possible solutions?

0

ssh does not accept the password in the format you are trying nor it can use the SOCKS proxy itself. The proxy command should use a ncat:

ProxyCommand ncat --proxy socks4host --proxy-type socks4 --proxy-auth username:password proxy.com portnum

or similar.

  • I used nc command. I am getting broken pipe error now. Is it possible to use socks5 with ncat? – Mani May 23 '17 at 13:18
  • Yes. Just have a look into the manual page to find out possible options. – Jakuje May 23 '17 at 13:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.