1

I try to automate ImDisk remote installation. I started with local experiments. At first to avoid kerberos double hop problem I copy imdiskinst.exe from UNC share to local folder C:\temp\. Then I run powershell:

$imdiskinstPath = "C:\temp\imdiskinst.exe"
Unblock-File $imdiskinstPath
Invoke-Command -Computername localhost -Scriptblock {
    $env:IMDISK_SILENT_SETUP="1";
    Start-Process -FilePath $imdiskinstPath -ArgumentList "-y" -Wait -PassThru
}

And installation really executes on remote server - I can see it by ProcessExplorer if not to set IMDISK_SILENT_SETUP so at the end it prompts about sucess. But when process is finished ImDisk is not installed. And if I execute the same script without -Computername localhost I have it done.

I have tried locally, really remotely, using PsExec instead of Invoke-Command and even found the advice to explicitely extract installer and do all other stuff manually. But why? It looks awkward. What's wrong with remote install?

  • Did you actually check in Programme Files or the x86 version? Who did you run the script as? You? – Julian Knight May 23 '17 at 22:14
  • @JulianKnight I checked in installed programs. I ran script from my account with administrative privilegies I'm in local admins. And all processes had Mandatory Label\High Mandatory Level – SerG May 24 '17 at 9:27
  • @SerG I am doing the exact same thing with imdisk! May I know if you have come up with any workaround with the InstallHInfSection issue since a month has passed? (For me, I am thinking about forcing PC to log in with local administrator account once on next reboot and deploying it via user logon instead of computer startup so that it is installed under administrator account) – wandersick Jun 24 '17 at 9:19
  • @wandersick Finally I just logged in to about 15 servers with RDP and install ImDisk. It was faster than to develop scalable solution against the awkward product. – SerG Jun 26 '17 at 15:52
0

Here is an alternative approach suggested to me by someone more expert than me.

Rather than trying to run the command directly, create a single run scheduled job on the remote machine and try running it that way.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.