2

I cracked my touchscreen on my Acer Laptop. This caused the screen to send continuous input events to the OS/window manager. Linux Mint uses mdm to initialize X-windows so I added the following line to the bottom of the script /etc/mdm/Init/Default.

xinput disable 10

I discovered the device ID by typing xinput with no arguments. This disables the input not only for the user but for the login screen and all users. Is this best practice for the situation?

3
  • 1
    "Is this best practice for the situation?" -- Not IMO. ADC conversions would still continuously be performed, but X11 would ignore every touch-generated datum. You should try to actually disable the TS controller hardware and the A-to-D conversions. I know how to do this in a Device Tree, but not for your "Acer laptop". Check your BIOS or UEFI. – sawdust May 24 '17 at 1:09
  • I initially went straight to the BIOS and no options were available. However sawdusts comment made me think about the battery power I may be using because the multi touch screen is still firing events to the kernel. I disabled the kernel module hid_multitouch module. – sfanjoy May 24 '17 at 22:15
  • see also unix.stackexchange.com/questions/127443/… – Tim Abell Jun 14 '19 at 12:32
2

I disabled the kernel module with help from

https://wiki.archlinux.org/index.php/Kernel_modules

as follows (as root):

  • lsmod | grep touch
  • Determine the module name (in my case hid_multitouch)
  • Create a file /etc/modprobe.d/blacklist-hid-multitouch.conf
  • Add line: # Cracked Screen disabling the kernel module
  • Add line: blacklist hid_multitouch
  • save file
  • reboot

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.